PAT (Advanced Level) Practice — 1124 Raffle for Weibo Followers (20 分)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/m0_37345402/article/details/87938822

题目链接:https://pintia.cn/problem-sets/994805342720868352/problems/994805350803292160

John got a full mark on PAT. He was so happy that he decided to hold a raffle(抽奖) for his followers on Weibo -- that is, he would select winners from every N followers who forwarded his post, and give away gifts. Now you are supposed to help him generate the list of winners.

Input Specification:

Each input file contains one test case. For each case, the first line gives three positive integers M (≤ 1000), N and S, being the total number of forwards, the skip number of winners, and the index of the first winner (the indices start from 1). Then M lines follow, each gives the nickname (a nonempty string of no more than 20 characters, with no white space or return) of a follower who has forwarded John's post.

Note: it is possible that someone would forward more than once, but no one can win more than once. Hence if the current candidate of a winner has won before, we must skip him/her and consider the next one.

Output Specification:

For each case, print the list of winners in the same order as in the input, each nickname occupies a line. If there is no winner yet, print Keep going... instead.

Sample Input 1:

9 3 2
Imgonnawin!
PickMe
PickMeMeMeee
LookHere
Imgonnawin!
TryAgainAgain
TryAgainAgain
Imgonnawin!
TryAgainAgain

Sample Output 1:

PickMe
Imgonnawin!
TryAgainAgain

Sample Input 2:

2 3 5
Imgonnawin!
PickMe

Sample Output 2:

Keep going...

:题意  给定m个人进行抽奖,第一个中奖的人的位置为s,从s开始,每隔n个人为下一个中奖的人,m个人中跳过重复存在人和已经中过奖的人。

#include<iostream>
#include<map>
using namespace std;
int main(){
	map<string,int>mapp;
	mapp.clear();
	int m,n,s;
	string a;
	cin>>m>>n>>s;
	bool f=0;
	for(int i=1;i<=m;i++){
		cin>>a;
		if(mapp[a]==1){
			s+=1;
		}
		if(i==s&&mapp[a]==0){
			cout<<a<<endl;
			mapp[a]=1;
			f=1;
			s+=n;
		}
	}
	if(!f){
		cout<<"Keep going..."<<endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/m0_37345402/article/details/87938822