HDU-1285 拓扑排序 字典序最小

版权声明:本文为博主原创文章,若需要引用、转载,只需注明来源及原文链接,若有错误,欢迎纠正。 https://blog.csdn.net/u014137295/article/details/87873017

Problem Description
有N个比赛队(1<=N<=500),编号依次为1,2,3,。。。。,N进行比赛,比赛结束后,裁判委员会要将所有参赛队伍从前往后依次排名,但现在裁判委员会不能直接获得每个队的比赛成绩,只知道每场比赛的结果,即P1赢P2,用P1,P2表示,排名时P1在P2之前。现在请你编程序确定排名。
Input
输入有若干组,每组中的第一行为二个数N(1<=N<=500),M;其中N表示队伍的个数,M表示接着有M行的输入数据。接下来的M行数据中,每行也有两个整数P1,P2表示即P1队赢了P2队。
Output
给出一个符合要求的排名。输出时队伍号之间有空格,最后一名后面没有空格。
其他说明:符合条件的排名可能不是唯一的,此时要求输出时编号小的队伍在前;输入数据保证是正确的,即输入数据确保一定能有一个符合要求的排名。

Sample Input
4 3
1 2
2 3
4 3
Sample Output
1 2 4 3
解题思路:
优先队列
代码:

#include<bits/stdc++.h>
#define maxn 504
using namespace std;
inline int read(){
    int x=0,f=0;char ch=getchar();
    while(ch>'9'||ch<'0')f|=ch=='-',ch=getchar();
    while(ch>='0'&&ch<='9')x=(x<<3)+(x<<1)+(ch^48),ch=getchar();
    return f?-x:x;
}
int n,m,i,in[maxn];
priority_queue<int,vector<int>,greater<int> >q;
vector<int>e[maxn],p;
void init(){
	for(int i=1;i<=n;++i)e[i].clear(),in[i]=0;
	while(!q.empty())q.pop();
	p.clear();
}
void topo(){
	for(i=1;i<=n;++i)if(in[i]==0) q.push(i);
	while (!q.empty()){
		int now=q.top();q.pop();
		p.push_back(now);
		for(i=0;i<e[now].size();++i)
			if (--in[e[now][i]]==0) q.push(e[now][i]);
	}
	for(i=0;i<p.size()-1;++i)printf("%d ",p[i]);
	printf("%d\n",p[p.size()-1]);
}
int main(){
	while(~scanf("%d%d",&n,&m)){
		init();
		while(m--){
			int u=read(),v=read();
			e[u].push_back(v);
			++in[v];
		}
		topo();
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/u014137295/article/details/87873017