PAT (Advanced Level) Practice 1030 Travel Plan

版权声明:copyright©CodeIover reserved https://blog.csdn.net/qq_40073459/article/details/87917935

A traveler's map gives the distances between cities along the highways, together with the cost of each highway. Now you are supposed to write a program to help a traveler to decide the shortest path between his/her starting city and the destination. If such a shortest path is not unique, you are supposed to output the one with the minimum cost, which is guaranteed to be unique.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers N, M, S, and D, where N (≤500) is the number of cities (and hence the cities are numbered from 0 to N−1); M is the number of highways; S and D are the starting and the destination cities, respectively. Then M lines follow, each provides the information of a highway, in the format:

City1 City2 Distance Cost

where the numbers are all integers no more than 500, and are separated by a space.

Output Specification:

For each test case, print in one line the cities along the shortest path from the starting point to the destination, followed by the total distance and the total cost of the path. The numbers must be separated by a space and there must be no extra space at the end of output.

Sample Input:

4 5 0 3
0 1 1 20
1 3 2 30
0 3 4 10
0 2 2 20
2 3 1 20

Sample Output:

0 2 3 3 40

 AC代码:

#include<cstdio> 
# include<cstring>
#include<algorithm>
using namespace std;
const int maxv = 510;
const int INF = 1000000000;
int n,m,st,ed,G[maxv][maxv],cost[maxv][maxv];
int d[maxv],c[maxv],pre[maxv];
bool vis[maxv] = {false};
void Dijkstra(int s){
	fill(d,d+maxv,INF);
	fill(c,c+maxv,INF);
	for(int i = 0;i < n;i++) pre[i] = i;
	d[s] = 0;
	c[s] = 0;
	for(int i = 0;i < n;i++){
		int u = -1,MIN = INF;
		for(int j = 0;j < n;j++){
			if(vis[j] == false && d[j] < MIN ){
				u = j;
				MIN = d[j];
			}
		}
		//找不到小于INF的d[u],说明剩下的顶点和起点不连通
		if(u == -1) return ;
		vis[u] = true;
		for(int v = 0;v <n;v++){
			if(vis[v] ==false&&G[u][v] !=INF){
				if(d[u] + G[u][v] < d[v]){
					d[v] = d[u] +G[u][v];
					c[v] = c[u] +cost[u][v];
					pre[v] = u;
				}else if(d[u] + G[u][v] == d[v]){
					if(c[u] +cost[u][v] < c[v]){
						c[v] = c[u] + cost[u][v];
						pre[v] = u;
					}
				}
			}
		}
	}
}
void DFS(int v){
	if(st == v){
		printf("%d ",v);
		return ;
	}
	DFS(pre[v]);
	printf("%d ",v);
}
int main(){
	scanf("%d%d%d%d",&n,&m,&st,&ed);
	int u,v;
	fill(G[0],G[0]+maxv*maxv,INF);
	for(int i =0;i<m;i++){
		scanf("%d%d",&u,&v);
		scanf("%d%d",&G[u][v],&cost[u][v]);
		G[v][u] = G[u][v];
		cost[v][u] = cost[u][v];
	}
	Dijkstra(st);
	DFS(ed);
	printf("%d %d\n",d[ed],c[ed]);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40073459/article/details/87917935