[UVA-11389] The Bus Driver Problem【贪心】

The Bus Driver Problem

In a city there are n bus drivers. Also there are n morning bus routes and n afternoon bus routes with
various lengths. Each driver is assigned one morning route and one evening route. For any driver, if
his total route length for a day exceeds d, he has to be paid overtime for every hour after the first d
hours at a flat r taka / hour. Your task is to assign one morning route and one evening route to each
bus driver so that the total overtime amount that the authority has to pay is minimized.
Input
The first line of each test case has three integers n, d and r, as described above. In the second line,
there are n space separated integers which are the lengths of the morning routes given in meters.
Similarly the third line has n space separated integers denoting the evening route lengths. The lengths
are positive integers less than or equal to 10000. The end of input is denoted by a case with three 0’s.
Output
For each test case, print the minimum possible overtime amount that the authority must pay.
Constraints
• 1 ≤ n ≤ 100
• 1 ≤ d ≤ 10000
• 1 ≤ r ≤ 5
Sample Input
2 20 5
10 15
10 15
2 20 5
10 10
10 10
0 0 0
Sample Output
50
0

链接:https://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=2384

简述:有n辆车,n条白天路线,n条黑夜路线,每辆车开一条白天路线跟一条黑夜路线,当两条路线加起来的长度超过d,加收r的费用。

分析:两个数组分别储存白天路线长度跟黑夜路线长度,将两个数组从小到大排序,如果最短的白天路线加最长的黑夜路线都超过d,其他都会超过d,此为最优解。

说明:贪心思想,以局部解来推最优解。

AC代码如下:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;
int n, d, r, i, sum, maxx, t;
int a[110], b[110];
int main()
{
	while (cin >> n >> d >> r && n )
	{
		
		for (i = 1; i <= n; i++) cin >> a[i];
		for (i = 1; i <= n; i++) cin >> b[i];
		sort(a+1, a + n + 1);
		sort(b+1, b + n + 1);
		t = 0;
		for (i = 1; i <= n; i++)
		{
			sum = a[i] + b[n - i+1];
			maxx = max(sum - d, 0);
			t += maxx * r;
		}
		cout << t << endl;
	}
	
}

猜你喜欢

转载自blog.csdn.net/qq_43966202/article/details/86693087