POJ - 1426 Find The Multiple【bfs】

Find The Multiple

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 46594 Accepted: 19448 Special Judge
Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input

2
6
19
0
Sample Output

10
100100100100100100
111111111111111111
Source

Dhaka 2002

简述:

说明:

分析:

AC代码如下:

#include <iostream>
#include <string.h>
#include <string>
#include <algorithm>
#include <stdio.h>
#include <queue>
using namespace std;
void bfs(int n)
{
	queue<long long>p;
	while(!p.empty())
	p.pop();
	p.push(1);
	while (1) {
		long long now = p.front();
		if (now % n == 0){
			cout << now << endl; 
			return;
		}
		p.pop();
		p.push(now * 10);
		p.push(now * 10 + 1);
	}
}
int main()
{
	int n;
	while (cin >> n && n) {
		bfs(n);
	}
}

猜你喜欢

转载自blog.csdn.net/qq_43966202/article/details/88084801