PAT A 1018(甲级)

版权声明:欢迎评论和转载,转载时请注明作者和出处,共同维护良好的版权和知识产权秩序。 https://blog.csdn.net/CrazyOnes/article/details/82502032

1018 Public Bike Management(30 分)

作者: CHEN, Yue

单位: 浙江大学

时间限制: 400 ms

内存限制: 64 MB

代码长度限制: 16 KB

There is a public bike service in Hangzhou City which provides great convenience to the tourists from all over the world. One may rent a bike at any station and return it to any other stations in the city.

The Public Bike Management Center (PBMC) keeps monitoring the real-time capacity of all the stations. A station is said to be in perfect condition if it is exactly half-full. If a station is full or empty, PBMC will collect or send bikes to adjust the condition of that station to perfect. And more, all the stations on the way will be adjusted as well.

When a problem station is reported, PBMC will always choose the shortest path to reach that station. If there are more than one shortest path, the one that requires the least number of bikes sent from PBMC will be chosen.

The above figure illustrates an example. The stations are represented by vertices and the roads correspond to the edges. The number on an edge is the time taken to reach one end station from another. The number written inside a vertex S is the current number of bikes stored at S. Given that the maximum capacity of each station is 10. To solve the problem at S​3​​, we have 2 different shortest paths:

  1. PBMC -> S​1​​ -> S​3​​. In this case, 4 bikes must be sent from PBMC, because we can collect 1 bike from S​1​​ and then take 5 bikes to S​3​​, so that both stations will be in perfect conditions.

  2. PBMC -> S​2​​ -> S​3​​. This path requires the same time as path 1, but only 3 bikes sent from PBMC and hence is the one that will be chosen.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 numbers: C​max​​ (≤100), always an even number, is the maximum capacity of each station; N (≤500), the total number of stations; S​p​​, the index of the problem station (the stations are numbered from 1 to N, and PBMC is represented by the vertex 0); and M, the number of roads. The second line contains N non-negative numbers C​i​​ (i=1,⋯,N) where each C​i​​ is the current number of bikes at S​i​​ respectively. Then M lines follow, each contains 3 numbers: S​i​​, S​j​​, and T​ij​​ which describe the time T​ij​​ taken to move betwen stations S​i​​ and S​j​​. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in one line. First output the number of bikes that PBMC must send. Then after one space, output the path in the format: 0−>S​1​​−>⋯−>S​p​​. Finally after another space, output the number of bikes that we must take back to PBMC after the condition of S​p​​ is adjusted to perfect.

Note that if such a path is not unique, output the one that requires minimum number of bikes that we must take back to PBMC. The judge's data guarantee that such a path is unique.

Sample Input:

10 3 3 5
6 7 0
0 1 1
0 2 1
0 3 3
1 3 1
2 3 1

Sample Output:

3 0->2->3 0

在一个公共自行车系统中,有多个自行车点和连接他们的路,现在给出一点V,要求求出从公共自行车调度中心到达V最短的路径,如果不唯一,就找出需要带出最少自行车数量的路径,如果仍然不唯一,就找出最少带回自行车数量的路径。

首先我们依然要确定需要使用Dijkstra算法去求解,在求出最短路径的同时,记录每一个点的前驱节点,然后使用DFS算法,分析每一条最短路径,找出一条符合题目输出条件的路径,并输出。


AC代码:

#include <cstdio>
#include <vector>
#include <algorithm>

using namespace std;

const int maxn = 510;
const int INF = 1000000000;
int cmax, n, des, m, minneed = INF, minremain = INF;
vector<int> pre[maxn], path, temp;
int G[maxn][maxn], c[maxn], d[maxn];
bool vis[maxn];

void dijkstra(int, int);
void dfs(int);

int main() {
    fill(G[0], G[0] + maxn * maxn, INF);
    scanf("%d%d%d%d", &cmax, &n, &des, &m);
    for(int i = 1; i <= n; ++i) {
        scanf("%d", c + i);
    }

    for(int i = 0; i < m; ++i) {
        int a, b, t;
        scanf("%d%d%d", &a, &b, &t);
        G[a][b] = G[b][a] = t;
    }

    dijkstra(0, des);
    dfs(des);

    printf("%d ", minneed);
    bool first = true;
    for(int i = path.size() - 1; i >= 0; --i) {
        if(!first) {
            printf("->");
        }
        printf("%d", path[i]);
        first = false;
    }
    printf(" %d", minremain);

    return 0;
}

void dijkstra(int s, int e) {
    fill(d, d + maxn, INF);
    d[s] = 0;

    for(int i = 0; i <= n; ++i) {
        int minv = -1, mindis = INF;
        for(int j = 0; j <= n; ++j) {
            if(!vis[j] && d[j] < mindis) {
                mindis = d[j];
                minv = j;
            }
        }

        if(minv == -1) {
            return ;
        }
        vis[minv] = true;
        for(int j = 0; j <= n; ++j) {
            if(!vis[j] && G[minv][j] != INF) {
                if(G[minv][j] + d[minv] < d[j]) {
                    d[j] = G[minv][j] + d[minv];
                    pre[j].clear();
                    pre[j].push_back(minv);
                } else if(G[minv][j] + d[minv] == d[j]) {
                    pre[j].push_back(minv);
                }
            }
        }
    }
}

void dfs(int v) {
    temp.push_back(v);
    if(v == 0) {
        int needbike = 0, remainbike = 0;
        for(int i = temp.size() - 2; i >= 0; --i) {
            if(c[temp[i]] >= cmax / 2) {
                remainbike += c[temp[i]] - cmax / 2;
            } else {
                int x = cmax / 2 - c[temp[i]];
                if(remainbike > 0) {
                    if(remainbike >= x) {
                        remainbike -= x;
                    } else {
                        needbike += x - remainbike;
                        remainbike = 0;
                    }
                } else {
                    needbike += x;
                }
            }
        }

        if(minneed > needbike) {
            minneed = needbike;
            minremain = remainbike;
            path = temp;
        } else if(minneed == needbike && minremain > remainbike) {
            minneed = needbike;
            minremain = remainbike;
            path = temp;
        }

        temp.pop_back();
        return ;
    }

    for(int i = 0; i < pre[v].size(); ++i) {
        dfs(pre[v][i]);
    }
    temp.pop_back();
}

如有错误,欢迎指摘。

猜你喜欢

转载自blog.csdn.net/CrazyOnes/article/details/82502032