C++ Pat甲级1006 Sign In and Sign Out (25 分)(字符串strcmp , strcpy)

1006 Sign In and Sign Out (25 分)

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133

输入:这一天的总记录数M 

        接下来包括M行记录 : 学号,进门时间,出门时间

输出:开门的人的学号  关门的人的学号


#include <cstdio>
#include <cstring>
using namespace std;
char firstTime[20]="23:59:59";
char lastTime[20]="00:00:00";
char firstPer[20];
char lastPer[20];
int main(){
    int n;
    char id[20],in[20],out[20];
    while(scanf("%d",&n)!=EOF){
        while(n--){
            scanf("%s%s%s",id,in,out);
            if(strcmp(firstTime,in)>0){ //进入的最早时间 
                strcpy(firstTime,in);
                strcpy(firstPer,id);
            }
            if(strcmp(lastTime,out)<0){ //出去的最晚时间 
                strcpy(lastTime,out);
                strcpy(lastPer,id);
            }
        }
        printf("%s %s",firstPer,lastPer);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_37503890/article/details/87894092