Binary Trees Aizu - ALDS1_7_B (构建二叉树)

Binary Trees Aizu - ALDS1_7_B

A rooted binary tree is a tree with a root node in which every node has at most two children.

Your task is to write a program which reads a rooted binary tree T and prints the following information for each node u of T:

node ID of u
parent of u
sibling of u
the number of children of u
depth of u
height of u
node type (root, internal node or leaf)
If two nodes have the same parent, they are siblings. Here, if u and v have the same parent, we say u is a sibling of v (vice versa).

The height of a node in a tree is the number of edges on the longest simple downward path from the node to a leaf.

Here, the given binary tree consists of n nodes and evey node has a unique ID from 0 to n-1.

Input

The first line of the input includes an integer n, the number of nodes of the tree.

In the next n lines, the information of each node is given in the following format:

id left right

id is the node ID, left is ID of the left child and right is ID of the right child. If the node does not have the left (right) child, the left(right) is indicated by -1.

Output

Print the information of each node in the following format:

node id: parent = p , sibling = s , degree = deg, depth = dep, height = h, type

p is ID of its parent. If the node does not have a parent, print -1.

s is ID of its sibling. If the node does not have a sibling, print -1.

deg, dep and h are the number of children, depth and height of the node respectively.

type is a type of nodes represented by a string (root, internal node or leaf. If the root can be considered as a leaf or an internal node, print root.

Please follow the format presented in a sample output below.

Examples

Sample Input 1
9
0 1 4
1 2 3
2 -1 -1
3 -1 -1
4 5 8
5 6 7
6 -1 -1
7 -1 -1
8 -1 -1
Sample Output 1
node 0: parent = -1, sibling = -1, degree = 2, depth = 0, height = 3, root
node 1: parent = 0, sibling = 4, degree = 2, depth = 1, height = 1, internal node
node 2: parent = 1, sibling = 3, degree = 0, depth = 2, height = 0, leaf
node 3: parent = 1, sibling = 2, degree = 0, depth = 2, height = 0, leaf
node 4: parent = 0, sibling = 1, degree = 2, depth = 1, height = 2, internal node
node 5: parent = 4, sibling = 8, degree = 2, depth = 2, height = 1, internal node
node 6: parent = 5, sibling = 7, degree = 0, depth = 3, height = 0, leaf
node 7: parent = 5, sibling = 6, degree = 0, depth = 3, height = 0, leaf
node 8: parent = 4, sibling = 5, degree = 0, depth = 2, height = 0, leaf

Hint

1 ≤ n ≤ 25




题意:

按照样例格式输入每个节点的编号和左右子节点, 要求构建二叉树并按编号顺序输出每个节点的相关信息, 格式见样例

题解:

按照题中要求构建二叉树, 节点数量不多, 直接使用结构体遍历就好.
还有一点问题就是题中要求高和深度了, 这两个我们另写两个函数来递归求出, 具体参见代码


#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;
#define ms(x, n) memset(x,n,sizeof(x));
typedef  long long LL;
const LL maxn = 30;
const int NIL = -1;

struct node{
    int p, l, r;
}T[maxn];
int N, D[maxn], H[maxn];
void setDepth(int u, int d){
    if(u == NIL) return;
    D[u] = d;
    setDepth(T[u].l, d+1);
    setDepth(T[u].r, d+1);
}
int setHeight(int u){
    int h1 = 0, h2 = 0;
    if(T[u].l != NIL) h1 = setHeight(T[u].l)+1;
    if(T[u].r != NIL) h2 = setHeight(T[u].r)+1;
    return H[u] = max(h1, h2);		//依次取较大的高
}
void print(int u){
    int sibling = -1, degree = 0;
    if(T[u].p!=NIL && u!=T[T[u].p].l) sibling = T[T[u].p].l;
    else if(T[u].p!=NIL && u!=T[T[u].p].r) sibling = T[T[u].p].r;
    if(T[u].l!=NIL) degree++;
    if(T[u].r!=NIL) degree++;

    printf("node %d: parent = %d, sibling = %d, degree = %d, depth = %d, height = %d, ",u,T[u].p,sibling,degree,D[u],H[u]);
    if(T[u].p==NIL) printf("root\n");
    else if(T[u].l==NIL && T[u].r==NIL) printf("leaf\n");
    else printf("internal node\n");
}
int main()
{
    for(int i = 0; i < maxn; i++) T[i].l = T[i].r = T[i].p = NIL;

    cin >> N;
    int l, r, id, root;
    for(int i = 1; i <= N; i++){
        cin >> id >> l >> r;
        T[id].l = l, T[id].r = r;
        T[l].p = T[r].p = id;
    }
    for(int i = 0; i < N; i++)
    if(T[i].p == NIL) root = i; //确定根节点

    setDepth(root, 0);
    setHeight(root);
    for(int i = 0; i < N; i++)
        print(i);

	return 0;
}

猜你喜欢

转载自blog.csdn.net/a1097304791/article/details/88220997