【PAT甲级】1125 Chain the Ropes (25 分)(思维)

版权声明:本人大三在读,有错误烦请指正,共同进步- ( ゜- ゜)つロ 乾杯~点赞请按右上角,转载请标明出处: https://blog.csdn.net/hzyhfxt/article/details/88067383

Given some segments of rope, you are supposed to chain them into one rope. Each time you may only fold two segments into loops and chain them into one piece, as shown by the figure. The resulting chain will be treated as another segment of rope and can be folded again. After each chaining, the lengths of the original two segments will be halved.

Your job is to make the longest possible rope out of N given segments.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (2≤N≤10​4​​). Then N positive integer lengths of the segments are given in the next line, separated by spaces. All the integers are no more than 10​4​​.

Output Specification:

For each case, print in a line the length of the longest possible rope that can be made by the given segments. The result must be rounded to the nearest integer that is no greater than the maximum length.

Sample Input:

8
10 15 12 3 4 13 1 15
Sample Output:

14

注意点:

1.全部绳子都要用上(第一次写,我理解错题意就挑了其中最长的两个绳子。。。居然还拿了8分)

2. 最先连接的绳子对折次数最多,损失最多,为了让绳子最长,排序后先连接短的绳

#include<cstdio>
#include<iostream>
#include<algorithm>
#define N 10010
using namespace std;
int a[N];
int main()
{
    int n;
    scanf("%d",&n);
    for(int i = 0;i < n;i++)
        scanf("%d",&a[i]);
    sort(a,a+n);
    int Max = a[0];
    for(int i = 1;i < n;i++)
        Max = (Max + a[i])/2;
    cout<<Max<<endl;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/hzyhfxt/article/details/88067383