How Many Tables(九度OJ 1445)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_37053885/article/details/88377807

How Many Tables(九度OJ 1445)

时间限制:1 秒 内存限制:32 兆 特殊判题:否

1.题目描述:

Today is Ignatius’ birthday. He invites a lot of friends. Now it’s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

输入:
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

输出:
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

样例输入:
2
5 3
1 2
2 3
4 5

5 1
2 5
样例输出:
2
4

2.基本思路

采用并查集,统计连通分量的个数。

3.代码实现

#include <iostream>
#define N 1001
using namespace std;
int Tree[N];

int findRoot(int x){
    if(Tree[x]==-1)return x;
    else {
        int tmp;
        tmp = findRoot(Tree[x]);
        Tree[x] = tmp;
        return tmp;
    }
}
int main()
{
    int T;
    int n,m;
    int a,b;
    scanf("%d",&T);
    for(int i=1;i<=T;i++){
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++){
            Tree[i]=-1;
        }
        for(int i=1;i<=m;i++){
            scanf("%d%d",&a,&b);
                int rootA = findRoot(a);
                int rootB = findRoot(b);
                if(rootA!=rootB){//若不在一个集合内
                    Tree[rootA] = rootB;//把集合A放入B中
                }
        }
        int ans=0;
        for(int i=1;i<=n;i++){
            if(Tree[i]==-1)
                ans++;
        }
        printf("%d\n",ans);
    }




    return 0;
}
/*
2
5 3
1 2
2 3
4 5

5 1
2 5
*/

猜你喜欢

转载自blog.csdn.net/qq_37053885/article/details/88377807