D - Anniversary party POJ - 2342

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
0 0 

Output

Output should contain the maximal sum of guests' ratings.

Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output

5

题目意思:有n个人,接下来n行是n个人的价值,再接下来n行给出l,k说的是l的上司是k,这里注意l与k是不能同时出现的

解题思路:

定义dp[i][0] 为第i个人不选择所获得的最大价值,dp[i][1] 为第i个人被选择所获得的最大价值

假设 j 是第i个人的下属, 那么有转移方程  :

扫描二维码关注公众号,回复: 5665205 查看本文章

dp[i][0]=dp[i][0]+max( dp[j][0],dp[j][1]);

dp[i][1]=dp[i][1]+dp[j][0]; 用dfs遍历这棵树,每个顶点被访问,且只被访问一次。

代码如下:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int n,q,p;
int dp[100000][20],f[100000];
int book[100000],b[100000];
void dfs(int t)
{
    b[t]=1;
    int i;
    for(i=1;i<=n;i++)
    {
        if(!b[i]&&f[i]==t)
        {
            dfs(i);
            dp[t][0]+=max(dp[i][0],dp[i][1]);  //如果t不去,取i去或不去的最大值
            dp[t][1]+=dp[i][0];                //如果t去了,则i 一定不去
        }
    }
}
int main()
{
    scanf("%d",&n);
    int i;
    for(i=1;i<=n;i++)
        scanf("%d",&dp[i][1]); //录入值去的值
    while(~scanf("%d%d",&q,&p)&&(p||q))
    {
        f[q]=p;
        book[q]=1;
    }
    int sum;
    for(i=1;i<=n;i++)
    {
        if(!book[i])
            sum=i;
    }
    dfs(sum);
    printf("%d\n",max(dp[sum][0],dp[sum][1]));
    return 0;
}

猜你喜欢

转载自blog.csdn.net/TANG3223/article/details/82083738