Jolly Jumpers

A sequence of n > 0 integers is called a jolly jumper if the absolute values of the difference between
successive elements take on all the values 1 through n − 1. For instance,
1 4 2 3
is a jolly jumper, because the absolutes differences are 3, 2, and 1 respectively. The definition implies
that any sequence of a single integer is a jolly jumper. You are to write a program to determine whether
or not each of a number of sequences is a jolly jumper.
Input
Each line of input contains an integer n ≤ 3000 followed by n integers representing the sequence.
Output
For each line of input, generate a line of output saying ‘Jolly’ or ‘Not jolly’.
Sample Input
4 1 4 2 3
5 1 4 2 -1 6
Sample Output
Jolly
Not jolly
代码

#include<bits/stdc++.h>
using namespace std;
set<int> s;
int main()
{
    int n;
    while(cin>>n)
    {
        int a;
        cin>>a;
        bool flag=true;
        for(int i=1;i<n;i++)
        {
            int b;
            cin>>b;
            int c=abs(a-b);
            a=b;
            if(s.count(c)==0&&c<n)
                s.insert(c);
            else
                flag=false;
        }
        if(flag)
            cout<<"Jolly"<<endl;
        else
            cout<<"Not jolly"<<endl;
        s.clear();
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43797508/article/details/88693366