POJ-1995 Rasing Modulo Numbers (快速幂取余)

                                                                               Raising Modulo Numbers

Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 10253   Accepted: 6236

Description

People are different. Some secretly read magazines full of interesting girls' pictures, others create an A-bomb in their cellar, others like using Windows, and some like difficult mathematical games. Latest marketing research shows, that this market segment was so far underestimated and that there is lack of such games. This kind of game was thus included into the KOKODáKH. The rules follow: 

Each player chooses two numbers Ai and Bi and writes them on a slip of paper. Others cannot see the numbers. In a given moment all players show their numbers to the others. The goal is to determine the sum of all expressions AiBi from all players including oneself and determine the remainder after division by a given number M. The winner is the one who first determines the correct result. According to the players' experience it is possible to increase the difficulty by choosing higher numbers. 

You should write a program that calculates the result and is able to find out who won the game. 
 

Input

The input consists of Z assignments. The number of them is given by the single positive integer Z appearing on the first line of input. Then the assignements follow. Each assignement begins with line containing an integer M (1 <= M <= 45000). The sum will be divided by this number. Next line contains number of players H (1 <= H <= 45000). Next exactly H lines follow. On each line, there are exactly two numbers Ai and Bi separated by space. Both numbers cannot be equal zero at the same time.

Output

For each assingnement there is the only one line of output. On this line, there is a number, the result of expression 

(A1B1+A2B2+ ... +AHBH)mod M.

Sample Input

3
16
4
2 3
3 4
4 5
5 6
36123
1
2374859 3029382
17
1
3 18132

Sample Output

2
13195
13

这道题的意思是输入一个T,有T组样例,每组样例先输入一个mod,再输入一个n,代表有n组数,每组数一个a,一个b,求a的b次方的和取余mod的值。

一个快速幂就好,不过一定注意判断n等零时返回1.

#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

long long mod;

long long sovle(long long a, long long n)
{
	if(n == 0)
		return 1;
    if(n == 1)
        return a;
	long long k = sovle(a, n / 2);
	if(n % 2 == 0)
		return k * k % mod;
	else
		return k * k * a % mod;
}

int main()
{
	int T;
	scanf("%d", &T);
	for(int cas = 1; cas <= T; cas++)
	{
		int n;
		scanf("%lld%d", &mod, &n);
		long long ans = 0;
		long long a, b;
		for(int i = 1; i <= n; i++)
		{
			scanf("%lld%lld", &a, &b);
			ans += sovle(a, b);
			ans = ans % mod;
		}
		printf("%lld\n", ans);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/someone_and_anyone/article/details/81145323