PAT A1048

  • 题目:
    Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 10​5​​ coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.
    Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤10​5​​, the total number of coins) and M (≤10​3​​, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.
Output Specification:

For each test case, print in one line the two face values V​1​​ and V​2​​ (separated by a space) such that V​1​​+V​2​​=M and V​1​​≤V​2​​. If such a solution is not unique, output the one with the smallest V​1​​. If there is no solution, output No Solution instead.
Sample Input 1:

8 15
1 2 8 7 2 4 11 15

Sample Output 1:

4 11

Sample Input 2:

7 14
1 8 7 2 4 11 15

Sample Output 2:

No Solution

  • 题目大意
    给出n个正整数和一个正整数m,问n个数字中是否存在一对数字a和b(a<=b)使得a+b成立。如果有多对,输出a最小的那一对

  • 分析
    1.value数组里面存放诶个数字出现的次数
    2.枚举1~1000里面的每个数字,若value[i]和value[m-i]都不为0,则输出则两个数。当m-i == i时,value[i] 里面的数字必须大于等于2

代码实现:

#include <cstdio>
int value[1001] = {0};
int main()
{
    int n, m, temp;
    scanf("%d%d", &n, &m);
    for(int i = 0; i < n; i++){
        scanf("%d", &temp);
        value[temp]++;;
    }
    if(m % 2 == 0){                    //单独判断m-i == i时
        if(value[m/2] >= 2){
            printf("%d %d", m/2, m/2);
            return 0;
        }
    }
    for(int i = 1; i <= m/2; i++){
        if(value[i] != 0  && value[m-i] != 0 && i != m-i){
            printf("%d %d", i, m-i);
            return 0;
        }
    }
    printf("No Solution");
    return 0;
}

猜你喜欢

转载自blog.csdn.net/xiao1guaishou/article/details/88946084