PAT --- 1008.Elevator (20 分)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/MissXy_/article/details/89224938

1008 Elevator (20 分)

The highest building in our city has only one elevator. A request list is made up with NNN positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer NNN, followed by NNN positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

3 2 3 1

Sample Output:

41

思路

数学题,一开始搞错了,脑子进水了,以为电梯每上一层就会停顿5秒,其实是电梯从开始层到终点层,在终点层停顿5秒。菜。。。

代码

#include <iostream>
using namespace std;

int main() {
	int n, secFlo, firFlo = 0, total = 0;
	cin >> n;
	for (int i = 0; i < n; i++) {
		cin >> secFlo;
		if (secFlo > firFlo) 
			total += (secFlo - firFlo) * 6;
		else 
			total += (firFlo - secFlo) * 4;
		total += 5;
		firFlo = secFlo;
	}
	cout << total;
}

猜你喜欢

转载自blog.csdn.net/MissXy_/article/details/89224938