POJ 2506 Tiling(大数)

版权声明:欢迎转载博客(转载时请附上原文链接^_^) https://blog.csdn.net/OneLine_/article/details/88831397

这是一道找规律的题目……

Tiling

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 11380   Accepted: 5258

Description

In how many ways can you tile a 2xn rectangle by 2x1 or 2x2 tiles? 
Here is a sample tiling of a 2x17 rectangle. 

Input

Input is a sequence of lines, each line containing an integer number 0 <= n <= 250.

Output

For each line of input, output one integer number in a separate line giving the number of possible tilings of a 2xn rectangle. 

Sample Input

2
8
12
100
200

Sample Output

3
171
2731
845100400152152934331135470251
1071292029505993517027974728227441735014801995855195223534251

一看这个数据就不简单……(就想到要用java做)

先把前四个数列出来

分别是 1 3 5 11

可以推出 a[i] = a[i-1] + a[i-2]*2

(其实是有思考过程的啦 但是脑子快废了 改天再补~~

放一下代码

import java.math.*;
import java.io.*;
import java.math.BigInteger;
import java.util.*;

//@SuppressWarnings(value = { "all" })

public class Main {

	public static void main(String[] args) {
		Scanner cin = new Scanner(System.in);
		// BigInteger zero = BigInteger.valueOf(0);

		BigInteger sum, n, ans;
		while (cin.hasNextBigInteger()) {
			BigInteger a = BigInteger.valueOf(1);
			BigInteger b = BigInteger.valueOf(3);
			BigInteger two = BigInteger.valueOf(2);
			n = cin.nextBigInteger();
			int N = n.intValue();
			for (int i = 1; i < N ; i++) {
				BigInteger c = a.multiply(two);
				c = c.add(b);
				a = b;
				b = c;
			}
			System.out.println(a);
		}
	}
}

猜你喜欢

转载自blog.csdn.net/OneLine_/article/details/88831397