Billboard

Billboard
Time Limit: 20000/8000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 30625 Accepted Submission(s): 12293

Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that’s why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.

Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.

Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can’t be put on the billboard, output “-1” for this announcement.

Sample Input
3 5 5
2
4
3
3
3

Sample Output
1
2
1
3
-1

题意:hw 的木板,放进一些 1L 的物品,求每次放空间能容纳且最上边的位子 思路:每次找到最大值的位子,然后减去 L 线段树功能:query:区间求最大值的位子(直接把 update 的操作在 query 里做了)

#include <iostream>
#include <cmath>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <set>
#include <queue>
#include <stack>
#define inf 0x3f3f3f3f
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
const long long mod = 1e9 + 7;
using namespace std;
typedef long long ll;
const int maxn = 222222;
int h,w,n;
int max1[maxn<<2];

void pushup(int rt){
    max1[rt]=max(max1[rt<<1],max1[rt<<1|1]);
}

void build(int l,int r,int rt){

        if(l==r){
             max1[rt]=w;
             return ;
        }
        int m=(l+r)>>1;
        build(lson);
        build(rson);
        pushup(rt);
}

int query(int x,int l,int r,int rt){
    if(l==r){
        max1[rt]-=x;
        return l;
    }
    int m=(l+r)>>1;
    int ret=(max1[rt<<1]>=x)?query(x,lson):query(x,rson);
    pushup(rt);
    return ret;
}

int main(){
    while(~scanf("%d%d%d",&h,&w,&n)){
        if(h>n)h=n;
        build(1,h,1);
        while(n--){
            int x;
            scanf("%d",&x);
            if(max1[1]<x)puts("-1");
            else printf("%d\n",query(x,1,h,1));
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/abc1235454/article/details/89245347