【bfs】献给阿尔吉侬的花束

【题目描述】

阿尔吉侬是一只聪明又慵懒的小白鼠,它最擅长的就是走各种各样的迷宫。今天它要挑战一个非常大的迷宫,研究员们为了鼓励阿尔吉侬尽快到达终点,就在终点放了一块阿尔吉侬最喜欢的奶酪。现在研究员们想知道,如果阿尔吉侬足够聪明,它最少需要多少时间就能吃到奶酪。

迷宫用一个R×C的字符矩阵来表示。字符S表示阿尔吉侬所在的位置,字符E表示奶酪所在的位置,字符#表示墙壁,字符.表示可以通行。阿尔吉侬在1个单位时间内可以从当前的位置走到它上下左右四个方向上的任意一个位置,但不能走出地图边界。

【输入】

第一行是一个正整数T(1 ≤ T ≤ 10),表示一共有T组数据。

每一组数据的第一行包含了两个用空格分开的正整数R和C(2 ≤ R, C ≤ 200),表示地图是一个R×C的矩阵。

接下来的R行描述了地图的具体内容,每一行包含了C个字符。字符含义如题目描述中所述。保证有且仅有一个S和E。

【输出】

对于每一组数据,输出阿尔吉侬吃到奶酪的最少单位时间。若阿尔吉侬无法吃到奶酪,则输出“oop!”(只输出引号里面的内容,不输出引号)。每组数据的输出结果占一行。

【输入样例】

3
3 4
.S..
###.
..E.
3 4
.S..
.E..
....
3 4
.S..
####
..E.

【输出样例】

5

1

oop!

【思路】:就是简单的bfs求最优解问题,直接跑bfs就完了注意要多组数据测试

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>
#include<map>
#include<string>
#include<cstring>
using namespace std;
const int maxn=999999999;
const int minn=-999999999;
int dir[4][2]= {{-1,0},{1,0},{0,-1},{0,1}};
inline int read() {
    char c = getchar();
    int x = 0, f = 1;
    while(c < '0' || c > '9') {
        if(c == '-') f = -1;
        c = getchar();
    }
    while(c >= '0' && c <= '9') x = x * 10 + c - '0', c = getchar();
    return x * f;
}
//字符S表示阿尔吉侬所在的位置,字符E表示奶酪所在的位置,字符#表示墙壁
struct node {
    int x,y,step;
};
int T,n,m,sx,sy,bx,by;
int visit[201][201];
char a[201][201];
int main() {
    cin>>T;
a:    while(T--) {
        int flag=0;
        memset(visit,0,sizeof(visit));
        cin>>n>>m;
        for(int i=1; i<=n; ++i) {
            for(int j=1; j<=m; ++j) {
                cin>>a[i][j];
                if(a[i][j]=='S') {
                    bx=i;
                    by=j;
                }
                if(a[i][j]=='E') {
                    sx=i;
                    sy=j;
                }
            }
        }
        queue<node>q;
        q.push((node) {
            bx,by,1
        });
        visit[bx][by]=1;
        while(!q.empty()) {
            node p=q.front();
            q.pop();
            for(int i=0; i<4; ++i) {
                int px=p.x +dir[i][0];
                int py=p.y +dir[i][1];
                if(px==sx&&py==sy) {
                    flag=1;
                    cout<<p.step<<endl;
                    goto a;
                }
                if(px>0&&px<=n&&py>0&&py<=m&&(a[px][py]=='.'||a[px][py]=='E')&&!visit[px][py]) {
                    visit[px][py]=1;
                    node kkk;
                    kkk.x=px;
                    kkk.y =py;
                    kkk.step=p.step+1;
                    q.push(kkk);
                }
            }
        }
        if(!flag) {
            cout<<"oop!\n";
        }
    }
    return 0;
}
 

猜你喜欢

转载自www.cnblogs.com/pyyyyyy/p/10732653.html