【POJ - 1330】Nearest Common Ancestors(lca,模板题)

版权声明:欢迎学习我的博客,希望ACM的发展越来越好~ https://blog.csdn.net/qq_41289920/article/details/89107923

题干:

A rooted tree is a well-known data structure in computer science and engineering. An example is shown below: 

 
In the figure, each node is labeled with an integer from {1, 2,...,16}. Node 8 is the root of the tree. Node x is an ancestor of node y if node x is in the path between the root and node y. For example, node 4 is an ancestor of node 16. Node 10 is also an ancestor of node 16. As a matter of fact, nodes 8, 4, 10, and 16 are the ancestors of node 16. Remember that a node is an ancestor of itself. Nodes 8, 4, 6, and 7 are the ancestors of node 7. A node x is called a common ancestor of two different nodes y and z if node x is an ancestor of node y and an ancestor of node z. Thus, nodes 8 and 4 are the common ancestors of nodes 16 and 7. A node x is called the nearest common ancestor of nodes y and z if x is a common ancestor of y and z and nearest to y and z among their common ancestors. Hence, the nearest common ancestor of nodes 16 and 7 is node 4. Node 4 is nearer to nodes 16 and 7 than node 8 is. 

For other examples, the nearest common ancestor of nodes 2 and 3 is node 10, the nearest common ancestor of nodes 6 and 13 is node 8, and the nearest common ancestor of nodes 4 and 12 is node 4. In the last example, if y is an ancestor of z, then the nearest common ancestor of y and z is y. 

Write a program that finds the nearest common ancestor of two distinct nodes in a tree. 
 

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case starts with a line containing an integer N , the number of nodes in a tree, 2<=N<=10,000. The nodes are labeled with integers 1, 2,..., N. Each of the next N -1 lines contains a pair of integers that represent an edge --the first integer is the parent node of the second integer. Note that a tree with N nodes has exactly N - 1 edges. The last line of each test case contains two distinct integers whose nearest common ancestor is to be computed.

Output

Print exactly one line for each test case. The line should contain the integer that is the nearest common ancestor.

Sample Input

2
16
1 14
8 5
10 16
5 9
4 6
8 4
4 10
1 13
6 15
10 11
6 7
10 2
16 3
8 1
16 12
16 7
5
2 3
3 4
3 1
1 5
3 5

Sample Output

4
3

题目大意:

n个点n-1条有向边,然后一个询问u,v 求两者的lca。

解题报告:

那部分注释掉的代码写哪个都可以。。。

AC代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<map>
#include<vector>
#include<set>
#include<string>
#include<cmath>
#include<cstring>
#define F first
#define S second
#define ll long long
#define pb push_back
#define pm make_pair
using namespace std;
typedef pair<int,int> PII;
const int MAX = 2e5 + 5;
int n;
int head[MAX];
struct Edge {
	int to,ne;
} e[MAX];
int tot;
void add(int u,int v) {
	e[++tot].to = v;
	e[tot].ne = head[u];
	head[u] = tot;
}
int fa[MAX][22],dep[MAX],in[MAX];
void dfs(int cur,int rt) {
	fa[cur][0] = rt;
	dep[cur] = dep[rt]+1;
	for(int i = 1; i<22; i++) {
		fa[cur][i] = fa[fa[cur][i-1]][i-1];
	}
	for(int i = head[cur]; i!=-1; i = e[i].ne) {
		int v = e[i].to;
		if(v == rt) continue;
		dfs(v,cur);
	}
}
int lca(int u,int v) {
	if(dep[u] < dep[v]) swap(u,v);//让u往上倍增 
	int dc = dep[u]-dep[v];
	for(int i = 21; i>=0; i--) {
		int now = fa[u][i];
		if(dep[now] >= dep[v]) u = now;
	}
//	for(int i = 0; i<22; i++) {
//		if((1<<i)&dc) u = fa[u][i];
//	}
	if(u == v) return u;
	for(int i = 21; i>=0; i--) {
		if(fa[u][i] != fa[v][i]) {
			u = fa[u][i];v = fa[v][i];
		}
	}
	return fa[u][0];
}
int main()
{	
	int t,u,v;
	cin>>t;
	while(t--) {		
		scanf("%d",&n);
		//init
		tot=0;
		for(int i = 1; i<=n; i++) head[i] = -1,in[i]=0;
		for(int i = 1; i<=n-1; i++) {
			scanf("%d%d",&u,&v);//u is v's parents
			add(u,v);
			in[v]++;
		}
		int tar;
		for(int i = 1; i<=n; i++) {
			if(in[i] == 0) {
				tar = i;break;
			}
		}
		dfs(tar,-1);
		scanf("%d%d",&u,&v);
		printf("%d\n",lca(u,v));
	} 
	return 0 ;
}
//20:32-20:50

猜你喜欢

转载自blog.csdn.net/qq_41289920/article/details/89107923