【PAT甲级】 Colors in Mars

Problem Description:  

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input Specification:

Each input file contains one test case which occupies a line containing the three decimal color values.

Output Specification:

For each test case you should output the Mars RGB value in the following format: first output #, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0 to its left.

Sample Input:

15 43 71

Sample Output:

#123456

解题思路:

这道题其实就是要求将3个10进制的数转换成13进制的数并进行输出。用str来存放每个数所对应的13进制下的字符。

AC代码: 

#include <bits/stdc++.h>
using namespace std;

int main()
{
    string str = "0123456789ABC";  //每个数所对应的13进制字符
    string result = "#";
    for(int i = 0; i < 3; i++)
    {
        int temp;
        cin >> temp;
        result = result + str[temp/13] + str[temp%13];
    }
    cout << result << endl;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_42449444/article/details/89046714