数据结构实验之串一:KMP简单应用 SDUT 2772

版权声明:转载请注明出处,谢谢。 https://blog.csdn.net/Mercury_Lc/article/details/89283419

Problem Description

给定两个字符串string1和string2,判断string2是否为string1的子串。

Input

 输入包含多组数据,每组测试数据包含两行,第一行代表string1(长度小于1000000),第二行代表string2(长度小于1000000),string1和string2中保证不出现空格。

Output

 对于每组输入数据,若string2是string1的子串,则输出string2在string1中的位置,若不是,输出-1。

Sample Input

abc
a
123456
45
abc
ddd

Sample Output

1
4
-1

Hint

Source

cjx

#include<stdio.h>
#include<cstring>
int next[1000000];
char str[1000000],substr[1000000];
void getnext()
{
    int i=0,j=-1;
    next[0]=-1;
    while(substr[i]!='\0')
    {
        if(j==-1||substr[i]==substr[j])
        {
            ++i;
            ++j;
            next[i]=j;
        }
        else
            j=next[j];
    }
}
int kmp()
{
    int i=0,j=0;
    int len1=strlen(str),len2=strlen(substr);
    while(i<len1&&j<len2)
    {
        if(j==-1||str[i]==substr[j])
        {
            ++i;
            ++j;
        }
        else
            j=next[j];
    }
    if(j>=len2)
       printf("%d\n",i-len2+1);
    else
        printf("-1\n");
}
int main()
{
    while(gets(str))
    {
        gets(substr);
        getnext();
        kmp();
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Mercury_Lc/article/details/89283419