Shaolin(map||set)

Shaolin

Shaolin temple is very famous for its Kongfu monks.A lot of young men go to Shaolin temple every year, trying to be a monk there. The master of Shaolin evaluates a young man mainly by his talent on understanding the Buddism scripture, but fighting skill is also taken into account. 
When a young man passes all the tests and is declared a new monk of Shaolin, there will be a fight , as a part of the welcome party. Every monk has an unique id and a unique fighting grade, which are all integers. The new monk must fight with a old monk whose fighting grade is closest to his fighting grade. If there are two old monks satisfying that condition, the new monk will take the one whose fighting grade is less than his. 
The master is the first monk in Shaolin, his id is 1,and his fighting grade is 1,000,000,000.He just lost the fighting records. But he still remembers who joined Shaolin earlier, who joined later. Please recover the fighting records for him. 

Input

There are several test cases. 
In each test case: 
The first line is a integer n (0 <n <=100,000),meaning the number of monks who joined Shaolin after the master did.(The master is not included).Then n lines follow. Each line has two integer k and g, meaning a monk's id and his fighting grade.( 0<= k ,g<=5,000,000) 
The monks are listed by ascending order of jointing time.In other words, monks who joined Shaolin earlier come first. 
The input ends with n = 0. 

Output

A fight can be described as two ids of the monks who make that fight. For each test case, output all fights by the ascending order of happening time. Each fight in a line. For each fight, print the new monk's id first ,then the old monk's id.

Sample Input

3
2 1
3 3
4 2
0

Sample Output

2 1
3 2
4 2

题意:

对于每一个新队友,找到与他实力最接近的老队友(优先选实力低的),然后新队员加入成老队员

解析:

扫描二维码关注公众号,回复: 6086099 查看本文章

明显用二分处理,查找与他实力最近的两位

set,map都能自动排序,选择任意一种解决

1.map&set

ac:

#include<bits/stdc++.h>
using namespace std;
map<int,int> mp;

set<int> st;
set<int>::iterator it;

int main()
{
    int n,x,j;
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0)
            break;
        st.clear();
        st.insert(1000000000);
        mp[1000000000]=1;
        if(n==0)
            break;
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d",&j,&x);
            mp[x]=j;
            it=st.lower_bound(x);
            if(it==st.end())
            {
                it--;
                printf("%d %d\n",j,mp[*it]);
            }
            else{
                int v=*it;
                if(it!=st.begin())
                {
                    it--;
                    int g=*it;//小的
                    if(abs(g-x)<=abs(v-x))
                        printf("%d %d\n",j,mp[g]);
                    else
                        printf("%d %d\n",j,mp[v]);
                }
                else
                    printf("%d %d\n",j,mp[*it]);
            }
            st.insert(x);
        }
    }
    return 0;
}

map

ac:

#include<bits/stdc++.h>
using namespace std;
map<int,int> mp;
map<int,int>::iterator it;

int main()
{
    int n,j,x;
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0)
            break;
        mp.clear();
        mp[1000000000]=1;
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&j,&x);
            it=mp.upper_bound(x);
            if(it==mp.end())
            {
                it--;
                printf("%d %d\n",j,it->second);
            }
            else{
                if(it==mp.begin())
                    printf("%d %d\n",j,it->second);
                else{
                    int v=it->first;
                    it--;
                    int g=it->first;
                    if(abs(g-x)<=abs(v-x))
                        printf("%d %d\n",j,it->second);
                    else
                        printf("%d %d\n",j,(++it)->second);
                }
            }
            mp[x]=j;
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_41183791/article/details/89437204