P1879 [USACO06NOV]玉米田Corn Fields 状压dp 经典题

版权声明:点个关注(^-^)V https://blog.csdn.net/weixin_41793113/article/details/89685016

题目描述

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

农场主John新买了一块长方形的新牧场,这块牧场被划分成M行N列(1 ≤ M ≤ 12; 1 ≤ N ≤ 12),每一格都是一块正方形的土地。John打算在牧场上的某几格里种上美味的草,供他的奶牛们享用。

遗憾的是,有些土地相当贫瘠,不能用来种草。并且,奶牛们喜欢独占一块草地的感觉,于是John不会选择两块相邻的土地,也就是说,没有哪两块草地有公共边。

John想知道,如果不考虑草地的总块数,那么,一共有多少种种植方案可供他选择?(当然,把新牧场完全荒废也是一种方案)

输入输出格式

输入格式:

第一行:两个整数M和N,用空格隔开。

第2到第M+1行:每行包含N个用空格隔开的整数,描述了每块土地的状态。第i+1行描述了第i行的土地,所有整数均为0或1,是1的话,表示这块土地足够肥沃,0则表示这块土地不适合种草。

输出格式:

一个整数,即牧场分配总方案数除以100,000,000的余数。

输入输出样例

输入样例#1: 复制

2 3
1 1 1
0 1 0

输出样例#1: 复制

9



因为state的空间没开够,1<<MAX写成了MAX,WA了N次
#include<iostream>
#include<cstdio>
using namespace std;

const int MAX = 15;
const int mod = 1e8;
int dp[MAX][1<<MAX];
int state[1<<MAX],F[MAX],field[MAX][MAX];
int m,n;

int main(){
    scanf("%d%d",&m,&n);

    for(int i=1;i<=m;i++)
    for(int j=1;j<=n;j++){
        scanf("%d",&field[i][j]);
        F[i] = (F[i]<<1) + field[i][j];
    }
    int tot = (1<<n)-1;
    int cnt=0;
    for(int i=0;i<=tot;i++)
        if(!((i<<1)&i))
            state[++cnt] = i;

    for(int i=1;i<=cnt;i++)
        if((state[i]&F[1])==state[i])//初始化第一行的状态
            dp[1][i] = 1;
            
    for(int i=2;i<=m;i++)//枚举每i行
        for(int j=1;j<=cnt;j++)//枚举第i行的状态
            if((state[j]&F[i])==state[j])
                for(int p=1;p<=cnt;p++)//枚举第i-1行的状态
                    if(!(state[j]&state[p]))
                        dp[i][j] = (dp[i][j] + dp[i-1][p])%mod;

    int ans=0;
    for(int i=1;i<=cnt;i++)
        ans = (ans+dp[m][i])%mod;

    printf("%d\n",ans);
    return 0;
}

另外一种风格,dp[0][0]=1,好处可以统一预处理

#include <bits/stdc++.h>
using namespace std;
const int M = 1e9;
int m, n, f[13][4096], F[13], field[13][13];
// max state: (11111111111)2 = (4095)10
bool state[4096];
int main()
{
    cin >> m >> n;
    for (int i = 1; i <= m; i++)
        for (int j = 1; j <= n; j++)
            cin >> field[i][j];
    for (int i = 1; i <= m; i++)
        for (int j = 1; j <= n; j++)
            F[i] = (F[i] << 1) + field[i][j];
    // F[i]: state on line i
    int MAXSTATE = 1 << n;
    for (int i = 0; i < MAXSTATE; i++)
        state[i] = ((i&(i<<1))==0) && ((i&(i>>1))==0);
    f[0][0] = 1;
    for (int i = 1; i <= m; i++)
        for (int j = 0; j < MAXSTATE; j++)
            if (state[j] && ((j & F[i]) == j))
                for (int k = 0; k < MAXSTATE; k++)
                    if ((k & j) == 0)
                        f[i][j] = (f[i][j] + f[i-1][k]) % M;
    int ans = 0;
    for (int i = 0; i < MAXSTATE; i++)
        ans += f[m][i], ans %= M;
    cout << ans << endl;
    getchar();
    getchar();
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_41793113/article/details/89685016