POJ 3660 传递闭包 弗洛伊德

http://poj.org/problem?id=3660

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ AN; 1 ≤ BN; AB), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined
 

Sample Input

5 5
4 3
4 2
3 2
1 2
2 5

Sample Output

2

题目大意: 有n头奶牛,给出m个关系,每个关系给出两头牛的编号A和B表示A战胜了B,问能确定排名的牛有多少头。

思路: 如果1头牛和其他n-1头牛的关系都知道的话,那么这头牛的排名就可以确定了。 因此我们可以用求传递闭包的算法来做。(用弗洛伊德也可以)

#include<iostream>
#include<cstdio>
#include<queue>
#include<algorithm>
#include<cstring>
#define INF 0x3f3f3f3f
using namespace std ;

int dp[105][105];

int main()
{
    int n,m;
    scanf("%d %d",&n,&m);
    for(int i=1;i<=n;i++)
        dp[i][i]=0;
    int t1,t2;
    for(int i=0;i<m;i++)
    {
        scanf("%d %d",&t1,&t2);
        dp[t1][t2]=1;
    }
    for(int k=1;k<=n;k++)
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
                dp[i][j]=dp[i][j]|(dp[i][k]&&dp[k][j]);
    int ans=0;
    for(int i=1;i<=n;i++)
    {
        int sum=0;
        for(int j=1;j<=n;j++)
        {
            if(dp[i][j]||dp[j][i])
                ++sum;
        }
        if(sum==n-1)
            ++ans;
    }
    printf("%d\n",ans);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/xiji333/article/details/89741450