Non-Prime Factors (质数筛选+因子分解)

转载自丿不落良辰的博客

https://cn.vjudge.net/problem/Kattis-nonprimefactors

Non-Prime Factors (质数筛选+因子分解)

For example, integer 100has the following nine factors: {1,2,4,5,10,20,25,50,100}. The two which are underlined are prime factors of 100 and the rest are non-prime factors. Therefore, NPF(100) = 7.

Input
The first line contains an integer Q(1≤Q≤3⋅10^6) denoting the number of queries. Each of the next Q lines contains one integer i (2≤i≤2⋅10^6).

Output
For each query i, print the value of NPF(i).WarningThe I/O files are large. Please use fast I/O methods.

Sample Input 1     

4
100
13
12
2018

Sample Output 1
7
1
4
2

#include <iostream>
#include <stdio.h>
#include <cmath>
using namespace std;
bool vis[2000005];
int ans[2000005];
void init()
{
    //开始筛,vis=1表示该数不是质数
    vis[1]=1;
    int m=sqrt(2000002+0.5);
    for(int i=2; i<=m; ++i)
    {
        if(!vis[i])
        {
            for(int j=i*i; j<=2000002; j+=i)
                vis[j]=1;
        }
    }
    //筛选结束
    for(int i = 1; i <= 2000000; ++i)
    {
        int rt = 2000000/i;
        for(int j = i; j <= rt; ++j)
        {
            if(vis[i]) //非质数
            {
                ans[i*j]++;
            }
            if(vis[j] && i!=j)
            {
                ans[i*j]++;
            }
        }
    }
}
int main()
{
    init();
    int Q;
    scanf("%d",&Q);
    while(Q--)
    {
        int n;
        scanf("%d",&n);
        printf("%d\n",ans[n]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_43417796/article/details/89790803