YTU 1082 Satellite Photographs

版权声明:转载请附上原文链接哟! https://blog.csdn.net/weixin_44170305/article/details/89919523

风华是一指流砂,苍老是一段年华。

题目描述

Farmer John purchased satellite photos of W x H pixels of his farm (1 <= W <= 80, 1 <= H <= 1000) and wishes to determine the largest 'contiguous' (connected) pasture. Pastures are contiguous when any pair of pixels in a pasture can be connected by traversing adjacent vertical or horizontal pixels that are part of the pasture. (It is easy to create pastures with very strange shapes, even circles that surround other circles.) 

Each photo has been digitally enhanced to show pasture area as an asterisk ('*') and non-pasture area as a period ('.'). Here is a 10 x 5 sample satellite photo: 

..*.....** 
.**..***** 
.*...*.... 
..****.*** 
..****.*** 

This photo shows three contiguous pastures of 4, 16, and 6 pixels. Help FJ find the largest contiguous pasture in each of his satellite photos.

输入

* Line 1: Two space-separated integers: W and H 
* Lines 2..H+1: Each line contains W "*" or "." characters representing one raster line of a satellite photograph.

输出

* Line 1: The size of the largest contiguous field in the satellite photo.

样例输入

copy

10 5
..*.....**
.**..*****
.*...*....
..****.***
..****.***

样例输出

16
#include<iostream>
#include<cstdio>
#include<cstring>
int t,ms;
int w,h,i,j;
char s[100][100];
using namespace std;
void sousuo(int i,int j)
{
    if(s[i][j]=='.'||i<0||j<0||i>=h||j>=w)
        return;
    if(s[i][j]=='*')
    {
        t++;
        s[i][j]='.';
        sousuo(i+1,j);
        sousuo(i,j+1);
        sousuo(i-1,j);
        sousuo(i,j-1);
    }
}
int main()
{
    cin>>w>>h;
    for(i=0;i<h;i++)
        for(j=0;j<w;j++)
            cin>>s[i][j];
    for(i=0;i<h;i++)
        for(j=0;j<w;j++)
    {
        t=0;
        if(s[i][j]=='*')
            sousuo(i,j);
            if(t>ms)
               ms=t;
    }
    cout<<ms<<endl;
}

猜你喜欢

转载自blog.csdn.net/weixin_44170305/article/details/89919523