C基础-计负均正

题目描述
从键盘输入任意20个整型数,统计其中的负数个数并求所有正数的平均值。
保留两位小数

样例输入
1 2 3 4 5 6 7 8 9 10
-1 -2 -3 -4 -5 -6 -7 -8 -9 -10
样例输出
10
5.50

参考代码

#include <iostream>
#include <iomanip>
using namespace std;
int main(){
   int A,posi=0;
   int nega=0;
   int sum=0;
   for(int i=0;i<20;i++){
     cin>>A;
     if(A<0)
       nega=nega+1;
     else if(A>0){
        posi++;
        sum+=A;
     }
    }
  cout<<nega<<endl;
  cout<<fixed<<setprecision(2)<<(double)sum/posi<<endl;
}

猜你喜欢

转载自blog.csdn.net/three_cats/article/details/90049367