hdu4965矩阵快速幂

One day, Alice and Bob felt bored again, Bob knows Alice is a girl who loves math and is just learning something about matrix, so he decided to make a crazy problem for her. 

Bob has a six-faced dice which has numbers 0, 1, 2, 3, 4 and 5 on each face. At first, he will choose a number N (4 <= N <= 1000), and for N times, he keeps throwing his dice for K times (2 <=K <= 6) and writes down its number on the top face to make an N*K matrix A, in which each element is not less than 0 and not greater than 5. Then he does similar thing again with a bit difference: he keeps throwing his dice for N times and each time repeat it for K times to write down a K*N matrix B, in which each element is not less than 0 and not greater than 5. With the two matrix A and B formed, Alice’s task is to perform the following 4-step calculation. 

Step 1: Calculate a new N*N matrix C = A*B. 
Step 2: Calculate M = C^(N*N). 
Step 3: For each element x in M, calculate x % 6. All the remainders form a new matrix M’. 
Step 4: Calculate the sum of all the elements in M’. 

Bob just made this problem for kidding but he sees Alice taking it serious, so he also wonders what the answer is. And then Bob turn to you for help because he is not good at math.

Input

The input contains several test cases. Each test case starts with two integer N and K, indicating the numbers N and K described above. Then N lines follow, and each line has K integers between 0 and 5, representing matrix A. Then K lines follow, and each line has N integers between 0 and 5, representing matrix B. 

The end of input is indicated by N = K = 0.

Output

For each case, output the sum of all the elements in M’ in a line.

Sample Input

4 2
5 5
4 4
5 4
0 0
4 2 5 5
1 3 1 5
6 3
1 2 3
0 3 0
2 3 4
4 3 2
2 5 5
0 5 0
3 4 5 1 1 0
5 3 2 3 3 2
3 1 5 4 5 2
0 0

Sample Output

14
56
#include <cstdio>
#include <cstring>
#include <iostream>
#define ll long long
using namespace std;
int n,m;

#define ll long long

int a[1005][10];
int b[10][1005];
int d[1005][10];
int e[1005][1005];
struct matrix
{
    int f[15][15];
    matrix()
    {
        memset(f,0,sizeof(f));
    }
};
matrix mul(matrix B,matrix A)
{
    int i,j,k;
    matrix C;
    for(i=1;i<=m;i++)
        for(j=1;j<=m;j++)
        for(k=1;k<=m;k++)
        C.f[i][j]=(C.f[i][j]+B.f[i][k]*A.f[k][j])%6;
    return C;

}
matrix pow(matrix A,ll p)
{
    matrix ans;
    for(int i=1;i<=m;i++)
        ans.f[i][i]=1;
    while(p)
    {
        if(p&1)
            ans=mul(ans,A);
        A=mul(A,A);
        p>>=1;
    }
    return ans;
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {if(n==0&&m==0)
    break;
        matrix c;

          memset(d,0,sizeof(d));
            memset(e,0,sizeof(e));
      for(int i=1;i<=n;i++)
        for(int j=1;j<=m;j++)
        scanf("%d",&a[i][j]);
      for(int i=1;i<=m;i++)
        for(int j=1;j<=n;j++)
        scanf("%d",&b[i][j]);
      for(int i=1;i<=m;i++)
        {for(int j=1;j<=m;j++)
        {for(int k=1;k<=n;k++)
        {c.f[i][j]=(c.f[i][j]+b[i][k]*a[k][j]);}
        c.f[i][j]%=6;
        }
        }
        c=pow(c,n*n-1);

      for(int i=1;i<=n;i++)
        {for(int j=1;j<=m;j++)
        {for(int k=1;k<=m;k++)
        {d[i][j]=(d[i][j]+a[i][k]*c.f[k][j]);}
        d[i][j]%=6;
        }
        }
        for(int i=1;i<=n;i++)
        {for(int j=1;j<=n;j++)
        {for(int k=1;k<=m;k++)
        {e[i][j]=(e[i][j]+d[i][k]*b[k][j]);}
        e[i][j]%=6;
        }
        }
    ll ans=0;
    for(int i=1;i<=n;i++)
        for(int j=1;j<=n;j++)
        ans+=e[i][j];
    printf("%lld\n",ans);

    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sdauguanweihong/article/details/90061664