c 十六进制A+B

Problem Description
There must be many A + B problems in our HDOJ , now a new one is coming.
Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too.
Easy ? AC it !

Input
The input contains several test cases, please process to the end of the file.
Each case consists of two hexadecimal integers A and B in a line seperated by a blank.
The length of A and B is less than 15.

Output
For each test case,print the sum of A and B in hexadecimal in one line.

Sample Input
+A -A
+1A 12
1A -9
-1A -12
1A -AA

Sample Output
0
2C
11
-2C
-90

#include<stdio.h>
void main()
{
	__int64 a,b,sum;
	while(scanf("%I64X %I64X",&a,&b)!=EOF)
	{
		sum=a+b;
		if(sum>=0)
			printf("%I64X\n",sum);
		else
			printf("-%I64X\n",-sum);
	}
}


猜你喜欢

转载自blog.csdn.net/qq_40811682/article/details/88317747