HDUOJ2057:

版权声明:qq836678589 https://blog.csdn.net/weixin_43924623/article/details/91040425

A + B Again

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 41377 Accepted Submission(s): 16837

Problem Description
There must be many A + B problems in our HDOJ , now a new one is coming.
Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too.
Easy ? AC it !

Input
The input contains several test cases, please process to the end of the file.
Each case consists of two hexadecimal integers A and B in a line seperated by a blank.
The length of A and B is less than 15.

Output
For each test case,print the sum of A and B in hexadecimal in one line.

Sample Input
+A -A
+1A 12
1A -9
-1A -12
1A -AA

Sample Output
0
2C
11
-2C
-90
直接计算:

#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
 
int main()
{
    __int64 a,b;
    while(~scanf("%I64X%I64X",&a,&b))
    {
        if(a + b >= 0)
            printf("%I64X\n",a+b);
        else
            printf("-%I64X\n",-(a+b));
    }
    return 0;
}

转换成十进制计算在转成16进制:

猜你喜欢

转载自blog.csdn.net/weixin_43924623/article/details/91040425