Currency Exchange (SPFA)

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency.
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR.
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real R AB, C AB, R BA and C BA - exchange rates and commissions when exchanging A to B and B to A respectively.
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations.
Input
The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10 3.
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10 -2<=rate<=10 2, 0<=commission<=10 2.
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10 4.
Output
If Nick can increase his wealth, output YES, in other case output NO to the output file.
Sample Input
3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00
Sample Output
YES

描述一下题意:
首先输入 货币种数N 交换点个数M 这个人有的货币代号S 这个人的货币量V
然后是B行
输入 货币代号A 货币代号B a-b汇率Rab a->b手续费Cab Rba Cba(略)
是否经过有限次的交换 ,能使钱变多
然后有个公式 (100 - 0.39) * 29.75 = 2963.3975RUR
用SPFA稍微变一下。

本来不会做,Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10 4. 这一句一直看不懂,后来看了一下题解,竟然一遍过了

/*
Sample Input
3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00
Sample Output
YES


*/ 
#include<iostream>
#include<cstdio> 
#include<cstring>
#include<queue>
using namespace std;
double r[105][105];  //i->j
double c[105][105];  //i->j
bool flag[105];   //true表示在队列 
double res[105];  //存储最后该种货币的量 
queue <int> q;
	int n,m,s;
	double v;
bool SPFA(){
	memset(flag,0,sizeof(flag));//不知道对不对 ,看来是对的 
	for(int i=1;i<=n;i++){
//		flag[i]==0;
		res[i]=0;
	}
	q.push(s);
	flag[s]=1;
	res[s]=v;
	while(!q.empty()){
		int newnode=q.front();
		q.pop();
		flag[newnode]=0;
		for(int i=1;i<=n;i++){
			if( res[i]< ( res[newnode]-c[newnode][i] ) * r[newnode][i] ){
				res[i]= ( res[newnode]-c[newnode][i] ) * r[newnode][i];
				if( !flag[i] ) q.push(i);
				if(res[s]>v) return true;
			}
		}
	}
	return false;
}
int main()
{
	cin>>n>>m>>s>>v;
	memset(r,0,sizeof(r));
	memset(c,0,sizeof(r));
	for(int i=0;i<m;i++){
		int a,b;
		double g,d,e,f;
		scanf("%d %d %lf %lf %lf %lf",&a,&b,&g,&d,&e,&f);
		r[a][b]=g;
		c[a][b]=d;
		r[b][a]=e;
		c[b][a]=f;
	}
	if(SPFA())
		cout<<"YES"<<endl;
	else cout<<"NO"<<endl;
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_44532671/article/details/92800497