PAT_B_1042 字符统计

题目描述

请编写程序,找出一段给定文字中出现最频繁的那个英文字母。

输入格式:
输入在一行中给出一个长度不超过 1000 的字符串。字符串由 ASCII 码表中任意可见字符及空格组成,至少包含 1 个英文字母,以回车结束(回车不算在内)。

输出格式:
在一行中输出出现频率最高的那个英文字母及其出现次数,其间以空格分隔。如果有并列,则输出按字母序最小的那个字母。统计时不区分大小写,输出小写字母。

输入样例:
This is a simple TEST.  There ARE numbers and other symbols 1&2&3...........
输出样例:
e 7

AC代码

//  PAT_1042_Count_Vocabulary 

# include <stdio.h>
# include <string.h>

int main(void)
{
	int Voc[26];
	int num, max;
	char S[1001];
	int i;
	
	gets(S);
	
	for (i=0; i<26; i++)
	{
		Voc[i]=0;
	}
	
	i=0;
	while (S[i] != '\0')
	{
		if (S[i]>='a' && S[i]<='z')
		{
			num = S[i] - 'a';
			Voc[num]++;
		}
		else if (S[i]>='A' && S[i]<='z')
		{
			num = S[i] - 'A';
			Voc[num]++;
		}
		i++;
	}

	max = 25;
	for (i=24; i>=0; i--)
	{
		if (Voc[i] >= Voc[max])
		{
			max = i;
		}
	}
	
	printf("%c %d",'a'+max,Voc[max]);
	
	return 0;
}

RR

猜你喜欢

转载自www.cnblogs.com/Robin5/p/11310297.html