hdu2717

Catch That Cow

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 19124    Accepted Submission(s): 5627


Problem Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
 

Input
Line 1: Two space-separated integers: N and K
 

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
 

Sample Input
 
  
5 17
 

Sample Output
 
  
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
 

Source

USACO 2007 Open Silver


注意点

多组输入

visit数组开大点

#include<bits/stdc++.h>
using namespace std;
struct node{
	int now;
	int step;
	node(){
		
	}
	node(int now,int step)
	{
		this->now = now;
		this->step = step;
	}
};
int n, k;
int visit[1000005]; 
int dir[2] = {-1,1};
int bfs()
{
	queue<node> q;
	q.push(node(n,0));
	visit[n] = 1;
	
	while(!q.empty())
	{
		node t = q.front();
		q.pop();
		if(t.now == k) return t.step;
		
		for(int i = 0;i < 2;i ++)
		{
			int tmp = t.now + dir[i];
			if(!visit[tmp] && tmp >= 0 && tmp <= 100000)
			{
				visit[tmp] = 1;
				q.push(node(tmp,t.step + 1));
			}
		}
		
		int tmp = t.now * 2;
		if(!visit[tmp] && tmp >= 0 && tmp <= 100000)
		{
			visit[tmp] = 1;
			q.push(node(tmp,t.step + 1));
		}
	}
	return 0;
}

int main()
{
	while(~scanf("%d%d",&n,&k))
	{
		memset(visit,0,sizeof(visit));
		cout << bfs() << endl;
	} 
    return 0;
}

猜你喜欢

转载自blog.csdn.net/soul_97/article/details/80278956