hdu1240

Asteroids!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5807    Accepted Submission(s): 3693


Problem Description
You're in space.
You want to get home.
There are asteroids.
You don't want to hit them.
 

Input
Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets.

A single data set has 5 components:

Start line - A single line, "START N", where 1 <= N <= 10.

Slice list - A series of N slices. Each slice is an N x N matrix representing a horizontal slice through the asteroid field. Each position in the matrix will be one of two values:

'O' - (the letter "oh") Empty space

'X' - (upper-case) Asteroid present

Starting Position - A single line, "A B C", denoting the <A,B,C> coordinates of your craft's starting position. The coordinate values will be integers separated by individual spaces.

Target Position - A single line, "D E F", denoting the <D,E,F> coordinates of your target's position. The coordinate values will be integers separated by individual spaces.

End line - A single line, "END"

The origin of the coordinate system is <0,0,0>. Therefore, each component of each coordinate vector will be an integer between 0 and N-1, inclusive.

The first coordinate in a set indicates the column. Left column = 0.

The second coordinate in a set indicates the row. Top row = 0.

The third coordinate in a set indicates the slice. First slice = 0.

Both the Starting Position and the Target Position will be in empty space.

 

Output
For each data set, there will be exactly one output set, and there will be no blank lines separating output sets.

A single output set consists of a single line. If a route exists, the line will be in the format "X Y", where X is the same as N from the corresponding input data set and Y is the least number of moves necessary to get your ship from the starting position to the target position. If there is no route from the starting position to the target position, the line will be "NO ROUTE" instead.

A move can only be in one of the six basic directions: up, down, left, right, forward, back. Phrased more precisely, a move will either increment or decrement a single component of your current position vector by 1.

 

Sample Input
 
  
START 1 O 0 0 0 0 0 0 END START 3 XXX XXX XXX OOO OOO OOO XXX XXX XXX 0 0 1 2 2 1 END START 5 OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO XXXXX XXXXX XXXXX XXXXX XXXXX OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO 0 0 0 4 4 4 END
 

Sample Output
 
  
1 0 3 4 NO ROUTE
 

Source

South Central USA 2001


简单bfs

#include<bits/stdc++.h>
using namespace std;
const int maxn = 15;
const int inf = 0x3f3f3f3f;
struct node{
	int x, y, z;
	int step;
	node(){
	}
	node(int x,int y,int z,int step){
		this->x = x;
		this->y = y;
		this->z = z;
		this->step = step;
	}
};
char mp[maxn][maxn][maxn]; 
int visit[maxn][maxn][maxn];
int sx, sy, sz, ex, ey, ez;
int n;
int res; 
int dir[6][3] = {{0,0,1},{0,0,-1},{1,0,0},{-1,0,0},{0,1,0},{0,-1,0}};
void bfs()
{
	queue<node> q;
	q.push(node(sx,sy,sz,0));
	visit[sx][sy][sz] = 1;
	
	while(!q.empty())
	{
		node t = q.front();
		q.pop();
		
		if(t.x == ex && t.y == ey && t.z == ez) 
		{
			res = t.step;
			return ;
		}
		for(int i = 0;i < 6;i ++)
		{
			int dx = t.x + dir[i][0];
			int dy = t.y + dir[i][1];
			int dz = t.z + dir[i][2];
			int tstep = t.step + 1;
			if(dx < 0 || dy < 0 || dz < 0 || dx >= n || dy >= n || dz >= n || visit[dx][dy][dz] || mp[dx][dy][dz] == 'X') continue;
			
			if(dx == ex && dy == ey && dz == ez)
			{
				res = tstep;
				return ;
			}
			q.push(node(dx,dy,dz,tstep));
			visit[dx][dy][dz] = 1;
		}
	}
}

int main()
{
	string s;
	while(cin >> s >> n)
	{
		res = inf;
		memset(visit,0,sizeof(visit));
		for(int i = 0;i < n;i ++)
		{
			for(int j = 0;j < n;j ++)
			{
				for(int k = 0;k < n;k ++)
				cin >> mp[j][k][i];
			}
		}
		cin >> sx >> sy >> sz;
		cin >> ex >> ey >> ez;
		
		cin >> s;
		
		bfs();
		
		if(res != inf)
		cout << n << " " << res << endl;
		else
		cout << "NO ROUTE" << endl;
	}
	return 0;
}


猜你喜欢

转载自blog.csdn.net/soul_97/article/details/80229535