Add More Zero

1772: Add More Zero

描述

题目描述:

There is a youngster known for amateur propositions concerning several mathematical hard problems.

Nowadays, he is preparing a thought-provoking problem on a specific type of supercomputer which has ability to support calculations of integers between 0 and ((2^m)−1) (inclusive).

As a young man born with ten fingers, he loves the powers of 10 so much, which results in his eccentricity that he always ranges integers he would like to use from 1 to 10^k (inclusive).

For the sake of processing, all integers he would use possibly in this interesting problem ought to be as computable as this supercomputer could.

Given the positive integer m, your task is to determine maximum possible integer k that is suitable for the specific supercomputer.

输入:

The input contains multiple test cases. Each test case in one line contains only one positive integer m, satisfying 1<=m<=10^5.

输出:

For each test case, output "Case #x: y" in one line (without quotes), where x indicates the case number starting from 1 and y denotes the answer of corresponding case.

样例输入
1
64
样例输出
Case #1: 0
Case #2: 19
 
        

题意:输入一个数m,求0到2^m-1范围内,使得10^k最大,求k

思路:10^k<=2^m-1 10^k<2^m 取对数 log10^k<log2^m k<m*log2/log10 k<m*log10(2)

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
using namespace std;
const double maxi=0.30102999566398;//log10(2)

int main()
{
    int num=1;
    int m;
    while(scanf("%d",&m)!=EOF)
    {
        printf("Case #%d: ",num);
        num++;
        double ans=m*maxi;
        cout<<(int)ans<<endl;
    }
    return 0;
}


理解错题是多么可怕  英语啊英语

猜你喜欢

转载自blog.csdn.net/soul_97/article/details/80210457
Add