HDU 1686 Oulipo(KMP+计算匹配成功次数)

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 33042 Accepted Submission(s): 12567

Problem Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e’. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T’s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A’, ‘B’, ‘C’, …, ‘Z’} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with |W| ≤ |T| ≤ 1,000,000.

Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output
1
3
0

解题思路:
求解完next数组后在原字符串中开始匹配直至匹配累加长度与串长度相等,之后next数组溯回,next数组溯回就已经是在之前能匹配程度最大的条件下再次累加长度进行继续匹配,这样每次累加到长达为串长度ans++
最后输出结果即可

#include<iostream>
#include<cstring>
using namespace std;

char t[1001010],p[10100];
int nex[10100];
int tlen,plen;
int ans,T;
void getnex()
{
    int j=0,k=-1;
    nex[0]=-1;
    while(j<plen)
    {
        if(k==-1||p[j]==p[k])
            nex[++j]=++k;
        else  k=nex[k];
    }
}

int KMP()
{
    if(tlen==1&&1==plen)
    {
        if(t[0]==p[0]) return 1;
        else return 0;
    }
    getnex();
    int i=0,j=0;
    for(;i<tlen;i++)
    {
        while(j>0&&t[i]!=p[j])
            j=nex[j];
        if(t[i]==p[j]) j++;
        if(j==plen)
        {
            ans++;
            j=nex[j];
        }
    }
    return ans;
}

int main()
{
    cin>>T;
    while(T--)
    {
        cin>>p>>t;
        ans=0;
        tlen=strlen(t);
        plen=strlen(p);
        cout<<KMP()<<endl;

    }
}
发布了247 篇原创文章 · 获赞 22 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/qq_43658924/article/details/102923935