1020 Tree Traversals (25 分)(已知后序+中序,求层序/还原树)

1020 Tree Traversals (25 分)

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:

4 1 6 3 5 7 2

the postorder sequence
后序序列

the inorder sequence
中序序列

#include<bits/stdc++.h>
#pragma GCC optimize(3)
#define max(a,b) a>b?a:b
using namespace std;
typedef long long ll;
struct node{
	int l,r;
}tr[100];
int hx[100];
int zx[100];
int dfs(int pr,int begin,int end){
	if(begin>end) return -1;
	int root=hx[pr],pos=begin;
	while(pos<=end&&zx[pos]!=root) pos++;
	tr[root].l=dfs(pr-(end-pos+1),begin,pos-1);
	tr[root].r=dfs(pr-1,pos+1,end);
	return root;
}
void cx(int n){
	int root=dfs(n,1,n);
	queue<int> q;
	q.push(root);
	while(n--){
		int p=q.front();
		q.pop();
		printf("%d%c",p," \n"[n==0]);
		if(tr[p].l!=-1) q.push(tr[p].l);
		if(tr[p].r!=-1) q.push(tr[p].r);
	}
}
int main(){
    int n;
    scanf("%d",&n);
    for(int i=1;i<=n;i++) scanf("%d",&hx[i]);
    for(int i=1;i<=n;i++) scanf("%d",&zx[i]);
    cx(n);
	return 0;
}





发布了415 篇原创文章 · 获赞 47 · 访问量 4万+

猜你喜欢

转载自blog.csdn.net/qq_42936517/article/details/103386219