codeforces-------Circle of Students

题目描述

There are n students standing in a circle in some order. The index of the i-th student is pi. It is guaranteed that all indices of students are distinct integers from 1 to n (i. e. they form a permutation).
Students want to start a round dance. A clockwise round dance can be started if the student 2 comes right after the student 1 in clockwise order (there are no students between them), the student 3 comes right after the student 2 in clockwise order, and so on, and the student n comes right after the student n−1 in clockwise order. A counterclockwise round dance is almost the same thing — the only difference is that the student i should be right after the student i−1 in counterclockwise order (this condition should be met for every i from 2 to n).

For example, if the indices of students listed in clockwise order are [2,3,4,5,1], then they can start a clockwise round dance. If the students have indices [3,2,1,4] in clockwise order, then they can start a counterclockwise round dance.

Your task is to determine whether it is possible to start a round dance. Note that the students cannot change their positions before starting the dance; they cannot swap or leave the circle, and no other student can enter the circle.

You have to answer q independent queries.

input

The first line of the input contains one integer q (1≤q≤200) — the number of queries. Then q queries follow.

The first line of the query contains one integer n (1≤n≤200) — the number of students.

The second line of the query contains a permutation of indices p1,p2,…,pn (1≤pi≤n), where pi is the index of the i-th student (in clockwise order). It is guaranteed that all pi are distinct integers from 1 to n (i. e. they form a permutation).

output

For each query, print the answer on it. If a round dance can be started with the given order of students, print “YES”. Otherwise print “NO”.

输入样例

5
4
1 2 3 4
3
1 3 2
5
1 2 3 5 4
1
1
5
3 2 1 5 4

输出样例

YES
YES
NO
YES
YES

判断一个圆环型的序列是否连续增长
C++代码

#include <bits/stdc++.h>
using namespace std;

const int Maxn = 205;

int q;
int n;
int a[Maxn];

int main()
{
    scanf("%d", &q);
    while (q--) {
        scanf("%d", &n);
        for (int i = 0; i < n; i++) {
            scanf("%d", &a[i]);
            a[i]--;
        }
        bool ok1 = true, ok2 = true;
        for (int i = 0; i < n; i++) {
            int ni = (i + 1) % n;  //ni  1,2,3...,n,0
            if ((a[i] + 1) % n != a[ni]) ok1 = false;  //顺着走
            if ((a[ni] + 1) % n != a[i]) ok2 = false;  //逆着走
        }
        printf("%s\n", (ok1 || ok2)? "YES": "NO");
    }
    return 0;
}
发布了52 篇原创文章 · 获赞 5 · 访问量 2277

猜你喜欢

转载自blog.csdn.net/advjj_058229/article/details/99550310