PAT甲级1099

1099 Build A Binary Search Tree (30 分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.

figBST.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100) which is the total number of nodes in the tree. The next Nlines each contains the left and the right children of a node in the format left_index right_index, provided that the nodes are numbered from 0 to N−1, and 0 is always the root. If one child is missing, then −1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

Output Specification:

For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42

Sample Output:

58 25 82 11 38 67 45 73 42
#include<bits/stdc++.h>
using namespace std;

struct Node{
	int data, lchild, rchild;
}node[110];
int n, wei[110], ind = 0;

void bct(int root){
	if(node[root].lchild != -1)
		bct(node[root].lchild);
	node[root].data = wei[ind++];
	if(node[root].rchild != -1)
		bct(node[root].rchild);
}

void levelorder(int root){
	queue<int> q;
	q.push(root);
	ind = 0;
	while(!q.empty()){
		int top = q.front();
		q.pop();
		printf("%d", node[top].data);
		if(++ind < n)
			printf(" ");
		if(node[top].lchild != -1)
			q.push(node[top].lchild);
		if(node[top].rchild != -1)
			q.push(node[top].rchild);
	}
}

int main(){
	scanf("%d", &n);
	for(int i = 0; i < n; i++)
		scanf("%d %d", &node[i].lchild, &node[i].rchild);
	for(int i = 0; i < n; i++)
		scanf("%d", &wei[i]);
	sort(wei, wei + n);
	bct(0);
	levelorder(0);
	return 0;
}
发布了116 篇原创文章 · 获赞 7 · 访问量 6038

猜你喜欢

转载自blog.csdn.net/qq_40204582/article/details/86772666