PAT甲级1102

1102 Invert a Binary Tree (25 分)

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can't invert a binary tree on a whiteboard so fuck off.

Now it's your turn to prove that YOU CAN invert a binary tree!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

本题给出的结点数据域是从小到大的,只要找到没有在左右结点中出现的数字,那个数字就是根节点。同时这道题是转置二叉树,所以在构建树时记得要把左右子树调换。

#include<iostream>
#include<algorithm>
#include<queue>
using namespace std;

struct Node{
	int data, lchild, rchild;
}node[20];
int n, levellist[40], inlist[40], numlevel = 0, numin = 0;
bool child[20] = { 0 };

void levelorder(int root){
	queue<int> q;
	q.push(root);
	while (!q.empty()){
		int top = q.front();
		q.pop();
		levellist[numlevel++] = top;
		if (node[top].lchild != -1)
			q.push(node[top].lchild);
		if (node[top].rchild != -1)
			q.push(node[top].rchild);
	}
}

void inorder(int root){
	if (root == -1)
		return;
	inorder(node[root].lchild);
	inlist[numin++] = root;
	inorder(node[root].rchild);
}

int main(){
	scanf("%d", &n);
	getchar();
	char a, b;
	for (int i = 0; i < n; i++){
		node[i].data = i;
		scanf("%c %c", &a, &b);
		getchar();
		if (a != '-'){
			node[i].rchild = a - '0';
			child[node[i].rchild] = true;
		}
		else
			node[i].rchild = -1;
		if (b != '-'){
			node[i].lchild = b - '0';
			child[node[i].lchild] = true;
		}
		else
			node[i].lchild = -1;
	}
	int root;
	for (int i = 0; i < n;i++)
	if (!child[i]){
		root = i;
		break;
	}
	levelorder(root);
	for (int i = 0; i < n;i++)
	if (i != n - 1)
		printf("%d ", levellist[i]);
	else
		printf("%d\n", levellist[i]);
	inorder(root);
	for (int i = 0; i < n; i++)
	if (i != n - 1)
		printf("%d ", inlist[i]);
	else
		printf("%d", inlist[i]);
	return 0;
}
发布了116 篇原创文章 · 获赞 7 · 访问量 6049

猜你喜欢

转载自blog.csdn.net/qq_40204582/article/details/86768377