HDU2008 数值统计【基础题】

数值统计

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 126475    Accepted Submission(s): 60823


Problem Description
统计给定的n个数中,负数、零和正数的个数。
 

Input
输入数据有多组,每组占一行,每行的第一个数是整数n(n<100),表示需要统计的数值的个数,然后是n个实数;如果n=0,则表示输入结束,该行不做处理。
 

Output
对于每组输入数据,输出一行a,b和c,分别表示给定的数据中负数、零和正数的个数。
 

Sample Input
 
  
6 0 1 2 3 -1 0 5 1 2 3 4 0.5 0
 

Sample Output
 
  
1 2 3 0 0 5
#include<bits/stdc++.h>  
using namespace std;  
int main(void)  
{  
    int n,m;  
    int t;  
    while(cin>>n>>m)  
    {  
        long sum = 0;  
        long s = 0;  
        if(n>m)  
        {  
            t = n;  
            n = m;  
            m = t;  
        }           //要注意比较大小否则不通过  
        for(int i = n; i <= m; i++)  
        {  
            if(i%2==0)  
                sum += i*i;  
            else  
                s += i*i*i;  
        }  
        cout<<sum<<" "<<s<<endl;  
    }  
    return 0;  
}  

猜你喜欢

转载自blog.csdn.net/wxd1233/article/details/80349784