HDU1096 A+B for Input-Output Practice (VIII)【基础题】

A+B for Input-Output Practice (VIII)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 184089    Accepted Submission(s): 55073


Problem Description
Your task is to calculate the sum of some integers.
 

Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.
 

Output
For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.
 

Sample Input
 
  
3 4 1 2 3 4 5 1 2 3 4 5 3 1 2 3
 

Sample Output
 
  
10 15 6
AC代码:
#include<stdio.h>
int main(void)
{
	int n;
	scanf("%d",&n);
	while(n--)
	{
		int sum = 0;
		int m;
		scanf("%d",&m);
		while(m--)
		{
			int a;
			scanf("%d",&a);
			sum += a;
		}
		printf("%d\n",sum);
		if(n>0)
			printf("\n");
	}
	return 0;
}


猜你喜欢

转载自blog.csdn.net/wxd1233/article/details/80321876