PAT (Advanced Level) Practice1008 Elevator (20 分)(Java实现)

Problem Description

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

3 2 3 1

Sample Output:

41

Code Example(Java)

import java.util.Scanner;

public class Main {

    public static void main(String[] args) {
        Scanner cin = new Scanner(System.in);
        int count = cin.nextInt();
        // 创建一个 count 的数组
        int[] arr = new int[count];

        int sum = count * 5;
        int preFloor = 0;
        for (int i = 0; i < count; i++) {
            int floor = cin.nextInt();
            // 计算 floor 与 上一个位置的楼层差
            int dis = floor - preFloor;

            sum += dis < 0 ? (Math.abs(dis) * 4) : dis * 6;

            preFloor = floor;
        }

        System.out.println(sum);
    }

}
发布了80 篇原创文章 · 获赞 13 · 访问量 9252

猜你喜欢

转载自blog.csdn.net/qq_39424178/article/details/99602016