FatMouse and Cheese HDU - 1078(DP)

FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he’s going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse – after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.
Input
There are several test cases. Each test case consists of

a line containing two integers between 1 and 100: n and k
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) … (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), … (1,n-1), and so on.
The input ends with a pair of -1’s.
Output
For each test case output in a line the single integer giving the number of blocks of cheese collected.
Sample Input
3 1
1 2 5
10 11 6
12 12 7
-1 -1
Sample Output
37

题意:
n * n的格子。
从(0,0)出发,可以沿着x轴和y轴走。每次最多走K距离。要求每次所到达的点比上次的点权值大。求走过的节点权值和最大值。

思路:
定义f[i][j]为点(i,j)的最大值。
子状态就是
f[i - k][j] ~ f[i + k][j]
f[i][j - k] ~ f[i][j + 1].
同时保证子状态的点权值小于等于当前点。
并且需要将dp初始化为-1,为-1的节点代表不可行的节点,不能从其转移过来。

#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

int f[105][105];
int a[105][105];
struct Node
{
    int x,y,v;
}nodes[10005];

int cmp(Node a,Node b)
{
    return a.v < b.v;
}

int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        if(n == -1 && m == -1)break;
        int cnt = 0;
        for(int i = 0;i < n;i++)
        {
            for(int j = 0;j < n;j++)
            {
                scanf("%d",&a[i][j]);
                if(i == 0 && j == 0)continue;
                nodes[++cnt].x = i;
                nodes[cnt].y = j;
                nodes[cnt].v = a[i][j];
            }
        }
        sort(nodes + 1,nodes + 1 + cnt,cmp);
        memset(f,-1,sizeof(f));
        f[0][0] = a[0][0];
        int ans = a[0][0];
        
        for(int i = 1;i <= cnt;i++)
        {
            int x = nodes[i].x,y = nodes[i].y;
            
            for(int j = max(0,x - m);j <= min(n - 1,x + m);j++)
            {
                if(a[j][y] >= a[x][y])continue;
                if(f[j][y] == -1)continue;
                
                f[x][y] = max(f[x][y],f[j][y] + a[x][y]);
            }
            
            for(int j = max(0,y - m);j <= min(n - 1,y + m);j++)
            {
                if(a[x][j] >= a[x][y])continue;
                if(f[x][j] == -1)continue;
                
                f[x][y] = max(f[x][y],f[x][j] + a[x][y]);
            }
            ans = max(ans,f[x][y]);
        }
        
        printf("%d\n",ans);
    }
    return 0;
}
发布了676 篇原创文章 · 获赞 18 · 访问量 3万+

猜你喜欢

转载自blog.csdn.net/tomjobs/article/details/104230436