PAT甲级-1071-Speech Patterns(map统计单词次数)

People often have a preference among synonyms of the same word. For example, some may prefer “the police”, while others may prefer “the cops”. Analyzing such patterns can help to narrow down a speaker’s identity, which is useful when validating, for example, whether it’s still the same person behind an online avatar.

Now given a paragraph of text sampled from someone’s speech, can you find the person’s most commonly used word?

Input Specification:

Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return \n. The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].

Output Specification:

For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a “word” is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.

Note that words are case insensitive.

Sample Input :
Can1: "Can a can can a can?  It can!"

Sample Output :
can 5

题目关键信息提取:
  • Here a “word” is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.The word should be printed in all lower case.
  • 可见单词的定义是:由一连串字母数字字符构成的,而被非字母数字字符 / 到达末尾所分割的一个字符串,且字母需要是小写形式。因此需要用到 isalnum() 和 tolower()函数,如下。
#include <cctype>
int isalnum(int c); //检查所传的字符是否是字母和数字
int tolower(int c);//将字母转换为小写
注意:

if(tmp.length()!=0) m[tmp]++;用来排除开头有一连串的空格,而被误以为是单词的情况。存放下一个单词前,tmp要清空一下!!!

代码如下

#include<iostream>
#include<map> 
#include<cctype>
using namespace std;

int main()
{
	string s,tmp;
	map<string, int> m;
	getline(cin, s);
	for(int i = 0; i < s.length(); i++){
		if(isalnum(s[i])){
			s[i] = tolower(s[i]);
			tmp += s[i];
		}
		if(!isalnum(s[i])||i==s.length()-1){
			if(tmp.length()!=0) m[tmp]++; 
			tmp="";
		}
	} 
	int  maxc = -1; string maxw;
	map<string, int>::iterator it;
	for(it = m.begin(); it != m.end(); it++){
		if(it->second > maxc) {
			maxc=it->second;maxw=it->first;
		}
	}
	cout<<maxw<<" "<<maxc;
	return 0;
}
发布了110 篇原创文章 · 获赞 746 · 访问量 3万+

猜你喜欢

转载自blog.csdn.net/qq_42437577/article/details/104171189