PAT (Advanced Level) 1031 Hello World for U (20分)JAVA实现

在这里插入图片描述

Sample Input:

helloworld!

Sample Output:

h !
e d
l l
lowor



import java.util.Scanner;

public class Main {
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		String str = sc.nextLine();
		int n = str.length();
		int n1=0;
		int n2=n;
		for (int i = 2; i < n; i++) {
			n2=n+2-2*i;
			if(n2<i) {
				i--;
				n1=i;
				n2=n+2-2*i;
				break;
			}
		}
		//System.out.println(n1+" "+n2);
		int space = n2-2;
		int head = 0;
		int tail =str.length()-1;
		n1--;
		int next = 0;
		while(n1-->0) {
			System.out.print(str.charAt(head));
			for (int i = 0; i < space; i++) {
				System.out.print(" ");
			}
			System.out.println(str.charAt(tail));
			head++;
			tail--;
			
		}
		
		//System.out.println("head:"+head+"  n2:"+n2);
		for (int i = head; i < n2+head; i++) {
			System.out.print(str.charAt(i));
		}
	}
	
}

在这里插入图片描述

发布了83 篇原创文章 · 获赞 1 · 访问量 1011

猜你喜欢

转载自blog.csdn.net/qq_44028719/article/details/104000682