PAT(A)1063 Set Similarity (25point(s))

在这里插入图片描述

Sample Input

3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3

Sample Output

50.0%
33.3%

思路:
判重,然后算重复率。
我本来想用map判重,最后一个点会超时,set在插入的时候就可以直接去重。
代码

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <string>
#include <cstring>
#include <vector>
#include <map>
#include <cmath>
#include <set>

using namespace std;

#define endl '\n'

typedef long long ll;


int main()
{
    int n;

    scanf("%d", &n);


    vector<set<ll> >v(n);

    for (int i = 0; i < n; ++i)
    {
        int m;
        scanf("%d", &m);

        set<ll>s;

        while (m--)
        {
            int x;
            scanf("%d", &x);

            s.insert(x);
        }

        v[i] = s;
    }

    int k;

    scanf("%d", &k);

    while (k--)
    {
        int x, y;
        scanf("%d %d", &x, &y);

        int nc = 0, nt = v[x - 1].size();

        for (auto it = v[y - 1].begin(); it != v[y - 1].end(); it++)
        {
            if (v[x - 1].find(*it) != v[x - 1].end())
                nc++;
            else
                nt++;
        }
        printf("%.1lf%%\n", nc * 100.0 / nt);
    }

    return 0;
}

发布了161 篇原创文章 · 获赞 7 · 访问量 7076

猜你喜欢

转载自blog.csdn.net/weixin_43778744/article/details/104229654