POJ 1089 Intervals (贪心)

Description

There is given the series of n closed intervals [ai; bi], where i=1,2,…,n. The sum of those intervals may be represented as a sum of closed pairwise non−intersecting intervals. The task is to find such representation with the minimal number of intervals. The intervals of this representation should be written in the output file in acceding order. We say that the intervals [a; b] and [c; d] are in ascending order if, and only if a <= b < c <= d.

Task

Write a program which:

reads from the std input the description of the series of intervals,

computes pairwise non−intersecting intervals satisfying the conditions given above,

writes the computed intervals in ascending order into std output

Input

In the first line of input there is one integer n, 3 <= n <= 50000. This is the number of intervals. In the (i+1)−st line, 1 <= i <= n, there is a description of the interval [ai; bi] in the form of two integers ai and bi separated by a single space, which are respectively the beginning and the end of the interval,1 <= ai <= bi <= 1000000.

Output

The output should contain descriptions of all computed pairwise non−intersecting intervals. In each line should be written a description of one interval. It should be composed of two integers, separated by a single space, the beginning and the end of the interval respectively. The intervals should be written into the output in ascending order.

Sample Input

5
5 6
1 4
10 10
6 9
8 10

Sample Output

1 4
5 10
以左端点排序~~

代码

#include<iostream>
#include<algorithm>
#include<string.h>
#include<queue>
#include<math.h>
#include<stack>
#include<stdio.h>
#define ll long long
#define inf 0x3f3f3f3f
using namespace std;
struct node
{
    int a,b;
};
node w[50005];
bool cmp(node a,node b)
{
    return a.a<b.a;
}
int main()
{
    //freopen("text.txt","r",stdin);
    int n;
    while(~scanf("%d",&n))
    {
        for(int i=0; i<n; ++i)
            scanf("%d %d",&w[i].a,&w[i].b);
        sort(w,w+n,cmp);
        int a=w[0].a,b=w[0].b;
        for(int i=1; i<n; ++i)
        {
            if(w[i].a>b)
            {
                printf("%d %d\n",a,b);
                a=w[i].a,b=w[i].b;
            }
            else if(w[i].b>b)
                b=w[i].b;
        }
        printf("%d %d\n",a,b);
    }
}

发布了145 篇原创文章 · 获赞 30 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/qq_43984169/article/details/95904316