HDU--1076--暴力查找

Ignatius was born in a leap year, so he want to know when he could hold his birthday party. Can you tell him?

Given a positive integers Y which indicate the start year, and a positive integer N, your task is to tell the Nth leap year from year Y.

Note: if year Y is a leap year, then the 1st leap year is year Y.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains two positive integers Y and N(1<=N<=10000).

Output

For each test case, you should output the Nth leap year from year Y.

Sample Input
3
2005 25
1855 12
2004 10000
Sample Output
2108
1904
43236

思路:判断闰年,ans++暴力统计;

bool check(int Y){
	if((Y%4==0&&Y%100!=0)||Y%400==0)	return true;
	return false;
} 
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
bool check(int Y){
	if((Y%4==0&&Y%100!=0)||Y%400==0)	return true;
	return false;
} 
int main(){
	int t;
	cin>>t;
	while(t--){
		int n,y,ans=0;
		cin>>y>>n;
		for(int i=y;;i++){
			if(check(i))  ans++;
			if(ans==n){
				printf("%d\n",i);
				break;
			}
		}
	}
} 
发布了170 篇原创文章 · 获赞 73 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/queque_heiya/article/details/104587868