POJ2236 (并查集)

题意描述

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.

Input
The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:

  1. “O p” (1 <= p <= N), which means repairing computer p.
  2. “S p q” (1 <= p, q <= N), which means testing whether computer p and q can communicate.

The input will not exceed 300000 lines.

Output
For each Testing operation, print “SUCCESS” if the two computers can communicate, or “FAIL” if not.

Sample Input
4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output
FAIL
SUCCESS

思路

这是一道并查集的扩展题。最开始时,我想的是维护一个储存pair的vector,但发现这样的话,实现并查集的合并操作就非常麻烦。看了题解才知道,只需要根据两点的距离来合并,不需要考虑的那么麻烦。可以使用一个数组来保存已经修复的电脑,然后每次对该数组进行遍历,如果两个电脑间的距离满足题意给的距离,那么就进行合并操作。最后再判断输出即可。

AC代码

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
#define IOS ios::sync_with_stdio(false); cin.tie(0);
using namespace std;
typedef pair<int,int> PII;
const int N=1010;
int n,m;
int p[N];
int dx[N],dy[N];
int repair[N];
int idx;
int find(int x){
	if(p[x]!=x) p[x]=find(p[x]);
	return p[x];
}
double dist(double x1,double y1,double x2,double y2){
	return sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
}
int main(){
	IOS;
	cin>>n>>m;
	for(int i=1;i<=n;i++){
		p[i]=i;
		cin>>dx[i]>>dy[i];
	}
	char op;
	int a,b;
	while(cin>>op>>a){
		if(op=='S') cin>>b;
		if(op=='O'){
			repair[idx++]=a;
			for(int i=0;i<idx-1;i++){
				if(dist(dx[repair[idx-1]],dy[repair[idx-1]],dx[repair[i]],dy[repair[i]])<=m){
					p[find(repair[i])]=find(repair[idx-1]);
				}
			}
		}else{
			if(find(a)==find(b)) cout<<"SUCCESS"<<endl;
			else cout<<"FAIL"<<endl;
		}
	}
	return 0;
}
发布了47 篇原创文章 · 获赞 33 · 访问量 2669

猜你喜欢

转载自blog.csdn.net/weixin_45729946/article/details/104636512